All times are UTC+02:00




Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 14 5 6 7 815 Next
Author Message
PostPosted: Sat Dec 01, 2018 10:48 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Stereo Tool 9.12 BETA012

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-012.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 12-012.exe
VST 2: http://www.stereotool.com/download/vst_ ... 12-012.dll
VST 3: http://www.stereotool.com/download/vst_ ... 2-012.vst3 DOES NOT YET WORK IN ALL PROGRAMS (vMIX for example)

Windows 64 bit:
Windows stand alone: -----://www.stereotool.com/download/stereo_tool ... 12-012.exe
VST 2: https://www.stereotool.com/download/vst ... 12-012.dll
VST 3: https://www.stereotool.com/download/vst ... 2-012.vst3 DOES NOT YET WORK IN ALL PROGRAMS (vMIX for example)


CHANGES:
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.


    OLD CHANGES:
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.


    TODO:
  • Remove library MicroMPX startup logging
  • Linux MicroMPX version (32 bit)
  • Linux MicroMPX version (64 bit)
  • Check new installer script
  • Is VST3 ok in vMIX after the latest build?
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Automate generating The BIMP licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian, NAB
  • VST for DJB
  • MicroMPX: highs idea BUSY -> Find beta testers TEST STOKKEMASK EFFECT TOMORROW
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Bug report: Linux version uses 100% CPU on one thread, even in bypass mode (must be sound card thread?) -> Not here. Not sure what's going on.....
  • Test ProppFrexx Windows 2012 server issue-
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • RDS: RT end at \n
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
PostPosted: Sun Dec 02, 2018 1:44 am 
User avatar

Joined: Tue Apr 05, 2011 1:20 pm
Posts: 149
The 32bit VST is creating a log file with the latest update. Is that supposed to happen?

It's an empty log file, until the plugin is exiting, when it writes
Quote:
info: Starting MicroMPX 1.4.3 beta / build 6870560
Kinda weird. :) I can't figure out where the file might be written to in Reaper, but it gets written in my own VST host, to the directory my host is in and starts from. File is just named "vst_stereo_tool.dll".

The previous build didn't write any log file.


Top
   
PostPosted: Mon Dec 03, 2018 3:58 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
The 32bit VST is creating a log file with the latest update. Is that supposed to happen?

It's an empty log file, until the plugin is exiting, when it writes
Quote:
info: Starting MicroMPX 1.4.3 beta / build 6870560
Kinda weird. :) I can't figure out where the file might be written to in Reaper, but it gets written in my own VST host, to the directory my host is in and starts from. File is just named "vst_stereo_tool.dll".

The previous build didn't write any log file.
Fixed! Next build won't write it anymore.
There were 2 issues:
1. It should have written to C:\Users\<username>\stereo_tool.log\
2. It should only have done that if you actually activated MicroMPX.
Both are solved in the next build.


Top
   
PostPosted: Tue Dec 04, 2018 8:33 am 
User avatar

Joined: Thu Oct 25, 2012 3:22 pm
Posts: 235
Location: Poland
In last beta I hear a lot of short sound drops, VLC input and wasapi output.

_________________
Urban Junglist


Top
   
PostPosted: Tue Dec 04, 2018 9:42 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
In last beta I hear a lot of short sound drops, VLC input and wasapi output.
Hm, I don't know what that can be. I haven't heard it. There was an issue with the new bass filter (it didn't add enough anymore), so I'm posting a new beta now. If you're still hearing it, could you make a recording?


Top
   
PostPosted: Tue Dec 04, 2018 9:44 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Stereo Tool 9.12 BETA013

Oops. Some setting was very wrong. This version didn't work properly without a license. Removed... New build tonight!


CHANGES:
  • Immersive bass: Protection to not add it if it's already there removed too much, now it's a slider. Value 1 = same as BETA012, value 10 = same as BETA011. Good range seems to be around 2-3. More testing needed.
  • Remove library MicroMPX startup logging
  • Linux MicroMPX version (32 bit)


    OLD CHANGES:
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.


    TODO:
  • Linux MicroMPX version (64 bit)
  • Is VST3 ok in vMIX after the latest build? - Should be better now, works here, and code is more logical.
  • Check new installer script
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Automate generating The BIMP licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian, NAB
  • VST for DJB
  • MicroMPX: highs idea BUSY -> Find beta testers TEST STOKKEMASK EFFECT TOMORROW
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Bug report: Linux version uses 100% CPU on one thread, even in bypass mode (must be sound card thread?) -> Not here. Not sure what's going on.....
  • Test ProppFrexx Windows 2012 server issue-
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • RDS: RT end at \n
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
PostPosted: Tue Dec 04, 2018 10:14 am 
User avatar

Joined: Thu Oct 25, 2012 3:22 pm
Posts: 235
Location: Poland
Beta 013 is totally broken, more drops and notifications in few seconds loop, drops sounds just like single or few samples error.

_________________
Urban Junglist


Top
   
PostPosted: Tue Dec 04, 2018 10:21 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
Beta 013 is totally broken, more drops and notifications in few seconds loop, drops sounds just like single or few samples error.
Yeah I just removed it, due to those notifications. I tested something and forgot to remove it. (It doesn't do this if you have a license).

But I don't get drops here.


Edit: New slider from 013 didn't sound good so we're back to what we had in 011.


Top
   
PostPosted: Tue Dec 04, 2018 2:03 pm 
User avatar

Joined: Thu Oct 25, 2012 3:22 pm
Posts: 235
Location: Poland
When I play stream with sine 40Hz@48kHz I see this drops also on visualisation waveform input and output.
I'll check on other machine, maybe VLC has some issue?
But when I play this stream direct in VLC player it sound wihout drops.

_________________
Urban Junglist


Top
   
PostPosted: Wed Dec 05, 2018 2:30 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Stereo Tool 9.12 BETA014

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-014.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 12-014.exe
VST 2: http://www.stereotool.com/download/vst_ ... 12-014.dll
VST 3: http://www.stereotool.com/download/vst_ ... 2-014.vst3

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-014.exe
VST 2: https://www.stereotool.com/download/vst ... 12-014.dll
VST 3: https://www.stereotool.com/download/vst ... 2-014.vst3


CHANGES:
  • Is VST3 ok in vMIX after the latest build? - Should be, works here, and code is more logical.
  • Immersive bass: Removed protection to not add too much again. It didn't have much effect, caused artifacts, and different compressor settings can give a very similar effect.
  • Remove MicroMPX startup logging in Stereo Tool/SST if not running, and put log file in user directory.
  • Linux MicroMPX version (32 bit)
  • Linux MicroMPX version (64 bit)


    OLD CHANGES:
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • RDS: RT end at \n
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.


    TODO:
  • Immersive Bass HPF output not working correctly
  • Immersive Bass HPF input for cleaner sound ? - Difficult to do, doesn't appear to do a lot anyway.
  • Preset change clipping
  • Preset add Wes
  • Made Immersive Bass movable (before Auto EQ, before AGC, after AGC - before it was always before AGC).
  • Presets DCM and Cerulean, Magic Gold and Paul: Check BS412 levels
  • Update version number
  • Release
    -
  • EON AF
  • Can you please check Pre-Limiter used with Normal limit making some strange effect with thresh under 3-4dB at 64 bands or less.
  • Check new installer script
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian
  • VST for DJB
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 14 5 6 7 815 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited