All times are UTC+02:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue May 17, 2022 8:32 pm 
User avatar

Joined: Mon Nov 30, 2015 5:05 pm
Posts: 23
Hi everyone,

just installed the latest uMPX image on my RPi 3B+ with IQAudio DAC+ (similar DAC as HifiBerry DAC+). FM output perfectly works with the sound card, but as soon as I enable the Demodulated output it rains errors in the log. See my attached picture. I cannot find an option to disable the FM MPX output, so can anyone tell me whats the problem?

Errors in log:
Failed to open soundcard stream: Device unavailable
Audio callback watchdog timeout. No data flow detected for 551.011 seconds.

Thanks in advance!
Kind regards,
Klaas-Jan


Top
   
PostPosted: Wed May 18, 2022 4:53 pm 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 141
Well, you probably need a second audio device to play the demodulated output.
You could do this:
- add a loopback audio interface (snd-aloop kernel module)
- set FM output to play into the loopback device
- set demodulated output to your actual audio device


Top
   
PostPosted: Fri May 27, 2022 12:42 pm 
User avatar

Joined: Mon Nov 30, 2015 5:05 pm
Posts: 23
Hi, thanks for your reply. I didn't know a second soundcard was necessary for that. I'll give it a try to get a loopback interface in addition, otherwise hook up a USB soundcard.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited