All times are UTC+02:00




Post new topic  Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed Dec 15, 2021 12:46 pm 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 135
Hi all -

anyone willing to share their µMPX settings? Like key-frame interval and error correction settings, or choice of bitrate.

Is there actually a need to adjust the defaults?


Top
   
PostPosted: Wed Dec 15, 2021 2:47 pm 
User avatar

Joined: Tue Sep 15, 2015 12:22 pm
Posts: 346
No not really, unless your connection is unstable. I'm using 64 (span) / 16 (overhead) for error correction. I'd suggest leaving keyframe interval and bitrate at their default value.

_________________
Some audio guy


Top
   
PostPosted: Wed Dec 15, 2021 6:06 pm 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 135
I'm running a test setup right now, and had drop-outs with 64/4, now trying 64/8.


Top
   
PostPosted: Thu Dec 16, 2021 6:39 am 

Joined: Fri Nov 23, 2012 4:34 pm
Posts: 207
Curious to know what your network is like that is seemingly causing issues?
Packet loss, jitter?


Top
   
PostPosted: Thu Dec 16, 2021 8:50 am 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 135
Now with 64/8 i got lots of messages like:
Quote:
2021-12-16 08:40:17.970 info: Recovered 1 blocks
2021-12-16 08:40:20.024 info: Recovered 2 blocks
2021-12-16 08:40:23.409 info: Recovered 1 blocks
2021-12-16 08:40:32.255 info: Recovered 1 blocks
2021-12-16 08:40:32.938 info: Recovered 1 blocks
2021-12-16 08:40:34.971 info: Recovered 1 blocks
2021-12-16 08:40:38.372 info: Recovered 1 blocks
2021-12-16 08:40:51.292 info: Recovered 1 blocks
2021-12-16 08:40:51.975 info: Recovered 1 blocks
2021-12-16 08:40:52.658 info: Recovered 1 blocks
2021-12-16 08:40:53.333 info: Recovered 1 blocks
2021-12-16 08:40:56.733 info: Recovered 1 blocks
which is not audible.

Internet Connection is both VDSL but on shared connection. I can't correlate the dropouts to high local usage yet.
The µMPX is also wrapped in a WireGuard VPN tunnel to make virtually fixed IPs and add some security.

µMPX decoder sometimes says it had recovered 1 lost packet but too late so silence was being played.


Top
   
PostPosted: Fri Dec 17, 2021 12:13 am 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 135
How can I best deal with this:
Quote:
Audio loss
0 Packets missing / 0 Packets too late / 1 Recovered but too late
Player 0.158 seconds of silence
BTW, I'm running ST 9.83 on Windows, µMPX Decoder on Pi4.


Top
   
PostPosted: Sat Dec 18, 2021 12:10 pm 

Joined: Fri Nov 23, 2012 4:34 pm
Posts: 207
How often do you have audio loss? If it is intermittent, it might be worthwhile setting up some form of network monitoring in an attempt to narrow down the issue?
When it occurs, does a traceroute provide any clues?


Top
   
PostPosted: Sat Dec 18, 2021 12:30 pm 
User avatar

Joined: Tue Sep 15, 2015 12:22 pm
Posts: 346
If you get the "recovered but too late" often it could also be an indication of that your recovery span (the 64) is too long compared to your playback delay (buffer). 64 is roughly 2/3s of a second, which means it can do any recovery every 0.66 seconds. If your playback delay is 1 second, it has 0.33 seconds to actually do the recovery before playback needs to happen. You could easily increase the playback delay or decrease the recovery span to find out.

_________________
Some audio guy


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited