Stereo Tool
https://forums.stereotool.com/

Sawtooth sweep every 20sec with WatchCat 2.0.0
https://forums.stereotool.com/viewtopic.php?f=26&t=30316
Page 1 of 1

Author:  TRENT310 [ Mon Mar 15, 2021 12:57 am ]
Post subject:  Sawtooth sweep every 20sec with WatchCat 2.0.0

Hello,

I just upgraded to the new WatchCat 2.0.0 and it looks like the "sawtooth sweep" artifacting is back, appearing at the beginning of every output file and repeating approximately every 20 seconds. Previously, on version 1.2.13 and earlier versions, this would only occur if I had more processing threads allocated (under Settings > Performance) than physically available in the hardware. However in this version even with Maximum processing threads limited to 1 (and regardless of the 'one thread per file' or 'multiple threads for one file' optimization setting), it happens with every file processed. This is processing FLAC 16- and 24-bit input to FLAC output with no sample rate conversion, queue input from a Watchfolder.

I have also tried reloading the Stereo Tool licence key in case this was some kind of trial mode limitation.
I have also removed and re-loaded the .sts preset file, which is the same one I was using with 1.2.13.
The StereoTool Preset file is optimized for my batch processing, and does not have any FM/MPX composite generation configuration.

Image

Image


To isolate the issue, I generated 1 minute of silence and encoded into a 16-bit, 44.1kHz .flac file. Then placed this .flac file into a watch folder monitored by WatchCat. WatchCat processed this file and output a new .flac file with the artifacting. So this appears to be independent of source content or dynamics.

I have since rolled back to 1.2.13 for now, and batch processing is working again with the same parameters as before, and also if I increase the processing thread limit back to 8 for fastest performance.

System is a Windows 10 Pro for Workstations x86_64 version 2004 build 10.0.19041.804, processor is a Xeon E3-1535M v6.

Author:  MrKlorox [ Mon Mar 15, 2021 9:01 am ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

Same here since the Watchcat released alongside beta ST 9.63_002. I tried basically everything listed as well, including 16-bit wav-to-wav with no processing. However, I didn't think about cores being the potential trigger. In the mean-time, I've gone back to using a DAW with the plugin for rendering audio the old way.

Does it now require a WC license for basic processing?

Win10 x64 20H2
ST License: Basic+Declipper+AdvancedDynamics

Author:  hvz [ Mon Apr 05, 2021 10:56 pm ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

This should only happen if you're using scripting or if you have multiple processing chains. In both cases, there should also be a message on top in WatchCat (with a red background) that indicates what's wrong:
Attachment:
wc.png
wc.png [ 20.6 KiB | Viewed 614 times ]

Can you confirm that you do not get this message? Because that would indicate a bug. Otherwise, the message should clarify what's wrong.

Author:  MrKlorox [ Mon Apr 05, 2021 11:28 pm ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

Quote:
This should only happen if you're using scripting or if you have multiple processing chains. In both cases, there should also be a message on top in WatchCat (with a red background) that indicates what's wrong:

wc.png


Can you confirm that you do not get this message? Because that would indicate a bug. Otherwise, the message should clarify what's wrong.
I do not get this message. I'd show a screenshot, but I cannot within this subforum. I even tried removing any existing presets for post scripting in case it's trying to do something there, and that didn't help. But now that I see there's supposed to be a message indicating something is in use without a license, I definitely feel like it's not behaving correctly.

Author:  chris1988 [ Tue Apr 06, 2021 3:55 pm ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

i just tried it with a preset with all licence features turned off. all typical sounds like the beeps and the voice message are gone but there is the sweep as mentioned above. on headphones i noticedd its also panning or doing phase inversion on one side and then the other during the sweep. using the mac version

Author:  MrKlorox [ Thu Apr 08, 2021 1:57 pm ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

Nice, the latest beta seems to fix this! Thanks

Author:  hvz [ Thu Apr 08, 2021 7:52 pm ]
Post subject:  Re: Sawtooth sweep every 20sec with WatchCat 2.0.0

I looked in a debugger what was wrong and I found that there's an issue with messages between different components in the software (sometimes a message didn't arrive). The part that caused the beeps is fixed, a build with some more issues solved is running now. You can get the latest version here (BETA012 has the fix for the beeps, BETA013, which i expect to post in a few hours, solves more issues, for example when cancelling files that are being processed).

viewtopic.php?f=14&t=30345

Page 1 of 1 All times are UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/