All times are UTC+01:00




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Aug 21, 2020 11:43 am 

Joined: Fri Aug 21, 2020 10:37 am
Posts: 4
Hi there,

I am using stereotool for over a year now and I am really satisfied with all the functions it has.
Stereotool is installed as standalone app on a windows 10 pc and it's processing the audio for my stream. Also stereotool is used to send the stream to a external icecast server.
This all worked fine until I recently noticed that my stream isn't showing the trackdata anymore. Stereotool is always updated with the latest version. To be honest I am not sure if this issue is started after I have updated stereotool since last 2 versions.
My playout software creates a txt file with artist and title information wich are separated by a - sing (example; artist - titlte)
In stereotool the trackdata is read from the specific txt file and the artist information is read from the file (upto -), while the title information is also read from the file (from -)

As I wrote before, the icecast server is from an external supplier. This means that I can only read out the dashboard. When checking that information, it noticed :"current song : null"

Now the questions wich I have are the following two.

1. Is there a way to readout the trackdata wich stereotool is sending to the icecast stream? Somewhere between stereotool and the icecast server the problem occurs. I would like to find out if it is stereotool that is causing the issue or it's the icecast server. (the audio is played well for your information)

2. Now my txt file is setup as 'artist - title'. Stereotool always seem to read this file. Is there a other standard setup for trackdata file wich is better for working in stereotool?


I hope someone can help me on this issue.


Ruud


Last edited by ruvo80 on Mon Aug 24, 2020 12:52 pm, edited 1 time in total.

Top
   
PostPosted: Fri Aug 21, 2020 11:27 pm 

Joined: Wed Jun 03, 2015 7:03 pm
Posts: 102
This setup works for me.
Image


Top
   
PostPosted: Sat Aug 22, 2020 11:44 pm 

Joined: Fri Aug 21, 2020 10:37 am
Posts: 4
I have the same settings, but it doesn't work.

That is why I hope it is possible to readout the data stereotool sends to the iceastserver


Top
   
PostPosted: Mon Aug 24, 2020 12:52 pm 

Joined: Fri Aug 21, 2020 10:37 am
Posts: 4
the problem is solved.

I found out that stereotool wasn't reading the file from a network drive. After placing the same file on a local drive and tried to read that file (wich worked).

Been looking how to make that work, since everything is on network drives in my studio. It was strange that my network drive wasn't accessible by stereotool.
After thinking a while I remembered that my nas had an update and been restarted. Stereotool apparently lost the network drive after my nas had a restart, so i just restarted Stereotool.
That was all to make it work again...

So problem is fixed!


Top
   
PostPosted: Mon Aug 24, 2020 10:02 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3579
Try run ST as admin. It's anyway stupid if it cannot read file over network.

_________________
control point


Top
   
PostPosted: Wed Aug 26, 2020 8:14 pm 

Joined: Fri Aug 21, 2020 10:37 am
Posts: 4
Important software is always run as admin on my computers ;)

The bug was that stereortool was running, the pc lost connection with the network drive and once the connection to the networkdrive was back connected to the pc, stereotool didn't find the drive again. somehow.

But it is fixed. (also the problem what made the networkdrive lost connection is fixed)


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited