All times are UTC+02:00




Post new topic  Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Glitchy Audio
PostPosted: Mon May 10, 2021 5:57 pm 

Joined: Sun May 09, 2021 6:06 am
Posts: 3
I have been using Stereo Tool for a while now and my music sound great! However, I have been having a problem that I can't figure out. Every once in a while (less than one time per minute up to a couple of times a minute) the sound will glitch, almost as if the computer froze for less then a second. I thought it was a buffer issue but the buffer stays rock solid. I have tried changing my sample rate, bit depth, latency, but nothing seems to fix the issue. I have tried different soundcards but the problem continues. I've also tried changing the input device driver/ASIO. A couple of things to note--when the audio glitches the processing display also freezes momentarily. This glitchy/freezing audio does NOT seem to be present on the streaming output.

For reference I am running Stereo Tool 9.50 (I have also tried different versions with no change)
Windows 7 Professional 64-bit
Intel Core 15 2400 running at 3.10 Ghz
8GB ram

Audio from RadioDJ (running on same computer)
ESI Juli@ set to 44100 24 bit
Using ASIO driver from input
Output to analog output on same card

Stereo Tool running at high proority
Latency set to 4096
Quality at 100%

Changing these settings did not have any effect on the glitchy audio


Top
   
 Post subject: Re: Glitchy Audio
PostPosted: Sun May 16, 2021 2:28 pm 

Joined: Wed Mar 23, 2016 5:41 pm
Posts: 21
What do you have the CPU and Latency set at. If this is set to low some presets will cause a glitch in the audio


Top
   
 Post subject: Re: Glitchy Audio
PostPosted: Mon May 17, 2021 3:36 pm 

Joined: Sun May 09, 2021 6:06 am
Posts: 3
Quote:
What do you have the CPU and Latency set at. If this is set to low some presets will cause a glitch in the audio
Processor priority: High
Latency: 4096 samples
Quality: 85% (Was running at 100% but lowered while troubleshooting)
Limit CPU: Limitless


Top
   
 Post subject: Re: Glitchy Audio
PostPosted: Fri May 21, 2021 4:02 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Please keep an eye on the CPU usage that Stereo Tool reports during a glitch (the display under CPU & Latency). If it jumps up at that point, something on your pc is blocking the processing.

Edit: Or your CPU jumps to a slower speed, that's also possible.


Top
   
 Post subject: Re: Glitchy Audio
PostPosted: Mon May 24, 2021 3:43 pm 

Joined: Sun May 09, 2021 6:06 am
Posts: 3
Quote:
Please keep an eye on the CPU usage that Stereo Tool reports during a glitch (the display under CPU & Latency). If it jumps up at that point, something on your pc is blocking the processing.

Edit: Or your CPU jumps to a slower speed, that's also possible.
Thanks for the suggestion. I monitored and never noticed a change in the CPU usage when a glitch happened. To further test, I ran a CPU benchmark to see if audio would glitch when the CPU was under heavy load but no glitches were noted. I also did the same with the hard drive with no effect.


Top
   
 Post subject: Re: Glitchy Audio
PostPosted: Wed May 26, 2021 11:07 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Try running this tool:
https://www.resplendence.com/latencymon

If there's a driver or something else that completely blocks something this will show it. Let it run and let it catch a glitch.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 6 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited