All times are UTC+02:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Wed Jan 12, 2022 4:54 pm 
User avatar

Joined: Wed Nov 08, 2017 3:16 pm
Posts: 168
ive been noticing this for quite awhile, very small minor overshoots past 0dB.
to reproduce this:
all sound data, stereo tool and sound card hardware is 16Bit @ 48Khz.
"exclusive" mode for sound card properties in windows is turned off.
64 bit windows 10, 64 bit Audacity, both updated to latest.
64 bit stereo tool 9.84 beta 15.
it does not matter what version or type of VB Audio virtual sound card is used or whether i use the built-in sound card or HDMI output to record the stereo tool output from (all at 16Bit 48Khz).
recording from any of these sources from the output of stereo tool using WASPI in Audacity at 16Bit 48Khz, shows very minor overshoots past 0dB in the recording (see attachment, red vertical lines).
i cannot attach the full configuration file from stereo tool to provide insight on the current settings because the file is too large, so here is a link to it instead (right click & save as) - http://www.scpdny.com/PC-STS.sts
these very small minor overshoots are visible on the output waveform of stereo tool at the slowest drawing speed (you have to look closely and use a large display of 1920x1080).
to be clear, i am recording the output from stereo tool to Audacity.
edit - confirmed this issue has nothing to do with "exclusive mode" under the windows properties for the sound cards being used, whether it is enabled or not makes no difference.
edit - after further investigation, this issue is significantly reduced if all inputs/outputs on stereotool are set to MME but the latency is increased as a result.
using WASPI/Kernel presents this issue prominently.


Attachments:
overshoots-1.jpg
overshoots-1.jpg [ 142.41 KiB | Viewed 732 times ]
overshoots.jpg
overshoots.jpg [ 239.71 KiB | Viewed 778 times ]
Top
   
PostPosted: Wed Mar 30, 2022 5:08 am 
User avatar

Joined: Wed Nov 08, 2017 3:16 pm
Posts: 168
found the fix.
increasing CPU (Audio Quality) from 100% to 150% corrects this issue, no more minor over shoots.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited