All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Jun 07, 2020 2:18 am 

Joined: Fri Oct 18, 2019 12:06 pm
Posts: 5
Hi,

I experience a very ugly sounding stream when I enable the following settings:
Under Streaming Output the 'Normal/Stream signal' is set to 'De-emphasized version of FM output' and 'Encode Stereo' is turned on.
It sounds like a very low-bitrate compressed MP3. When I disable Encode Stereo in FM settings, this problem is gone.

Is Stereo Tool trying to send the high-frequency MPX signal through the OGG/MP3 stream? I don't hear much of a difference when RDS is toggled.

Thanks a lot,
Gabriel

Edit: This was due to the Limit CPU setting that was transferred wrongly to the new version. Now I've set it to Limitless, Follow Preset and it works fine again.


Top
   
PostPosted: Mon Jul 06, 2020 1:56 am 

Joined: Sun Dec 07, 2014 12:41 am
Posts: 25
Thanks for this post. Perhaps the issue I just experienced is also related to this. After upgrading from 9.40 to 9.50 (Winamp DSP plugin) the FM output sounded very poor, much like you described but with a "chh..chh..chh.." sound along with the audio. I've never had a bad experience before when upgrading ST and had just tested 9.50 in our test environment without this issue. I ended up downgrading back to 9.40 and the audio sounded normal again.

I too discovered the CPU usage setting seemed to correct the issue, but not completely. I will try upgrading again, set the CPU to Limitless and see if that works in a second attempt.

Thanks


Top
   
PostPosted: Mon Jul 06, 2020 6:29 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10086
Found it. Under Composite clipper, there are 2 settings: "Also lows" and "Also highs". Meaning that they also are composite clipped. (Which is actually not really that useful). Anyway, if you enable Also lows but *not* Also highs, which makes even less sense, it breaks. And, Also highs is turned off in lower CPU settings, Also lows was not.

I am changing the behavior now, such that Also lows automatically also does Also highs, and lower CPU modes turn both off.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited