All times are UTC+01:00




Post new topic  Reply to topic  [ 186 posts ]  Go to page Previous 13 4 5 6 719 Next
Author Message
PostPosted: Sat Nov 26, 2022 12:05 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
Posted BETA007, no big changes but the new I/O framework is now also available in the Winamp build with new GUI, and the meter ordering on the overview page is improved (matching what happens in the software; removing things that are turned off). We will first fix the issues that were reported in the previous few posts (different sound card block sizes) before we also convert the VST.


Top
   
PostPosted: Sat Nov 26, 2022 12:07 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
Quote:
I'm only afraid to ask about resampler with separate I/O samplerates. :roll:
That would also require sound cards to be opened with different sample rates, and we don't have that yet... And I don't know if we really should? Can you tell me why you would need this? I can't promise how fast we would be able to look into this, but at least I could put it on the list of wanted features.


Top
   
PostPosted: Sat Nov 26, 2022 12:36 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 4080
Quote:
Quote:
I'm only afraid to ask about resampler with separate I/O samplerates. :roll:
That would also require sound cards to be opened with different sample rates, and we don't have that yet... And I don't know if we really should? Can you tell me why you would need this? I can't promise how fast we would be able to look into this, but at least I could put it on the list of wanted features.
idk how to respond to this, i'll give one example, now when input2 is working, i need to setup "some" player to play music, and most of the time music is 44.1, meaning, or windows or soundcard/virtual soundcard must do resample and none of them do it right.
https://youtu.be/bmGLtJtHxek?t=407

_________________
control point


Top
   
PostPosted: Mon Nov 28, 2022 5:04 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
For MME, Wasapi, KS: The latency with identical settings is 1 I/O block lower for the new I/O layer than for the old with the same settings. I don't think that I want to change that, because it would increase the lowest possible latency. But settings that are on-the-edge could fail after updating. Usually an I/O block is about 10 ms.


Top
   
PostPosted: Mon Nov 28, 2022 7:04 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 4080
Quote:
For MME, Wasapi, KS: The latency with identical settings is 1 I/O block lower for the new I/O layer than for the old with the same settings. I don't think that I want to change that, because it would increase the lowest possible latency. But settings that are on-the-edge could fail after updating. Usually an I/O block is about 10 ms.
with that one added block still lower then old?
also, xp ini file fixed in beta7 / edit: it's fixed.

_________________
control point


Top
   
PostPosted: Mon Nov 28, 2022 11:50 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
Quote:
with that one added block still lower then old?
Yes, it appears to be 1 block lower. So typically 10 ms.
Quote:
also, xp ini file fixed in beta7 / edit: it's fixed.
Great!


Top
   
PostPosted: Tue Nov 29, 2022 10:12 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
New version with the old I/O behavior is posted. Only for stand alone and DSP; VST is half-way finished and hence partially broken.


Top
   
PostPosted: Wed Nov 30, 2022 2:24 am 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 4080
Sync now works even nicer, but once i had "M" lock to 2.0000 but it happened once, now whole day not.
edit: happened again.
edit2: going back to beta7.

_________________
control point


Top
   
PostPosted: Wed Nov 30, 2022 8:25 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
Quote:
Sync now works even nicer, but once i had "M" lock to 2.0000 but it happened once, now whole day not.
edit: happened again.
edit2: going back to beta7.
The only change in 008 that the block size behavior is the same as before, but with slightly lower latency, it might be easier to make it misbehave. However, M at 2.0000 isn't neccessarily a problem - did it cause issues or not get out of it anymore?

What did you set the latency to? I think you set it really low, correct? Since the latency is 1 block lower than in the old framework, that might explain this, if it was already on the edge before.


Top
   
PostPosted: Wed Nov 30, 2022 8:36 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10853
BETA009 is posted; new I/O behavior now also available in the VST2 plugin.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 186 posts ]  Go to page Previous 13 4 5 6 719 Next

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited