All times are UTC+02:00




Post new topic  Reply to topic  [ 50 posts ]  Go to page Previous 1 2 3 4 5
Author Message
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu May 26, 2022 9:20 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10579
Quote:
Quote:
Ok quick update:

I think I have found where the problem is.

It seems if you have the 'Spectral Hole Filler' enabled, under the Delossifier' section.
This stops 'Bass Exciter' from working.

I found this on my test machine, while trying to find which setting was stopping
Bass Exciter from working.
I just found this too, soon as I turn on Delossifier, Bass Exciter stops working. Thanks for the fix, at least!
Oops. Found & fixed. New beta is building now, and I'll upload it in probably about 2 hours.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu May 26, 2022 11:54 am 

Joined: Sat Oct 14, 2017 3:31 am
Posts: 77
Quote:
What player are you using, and is Stereo Tool running inside it? Because a crossfading plugin can also cause weird issues if it's in the same group of plugins as Stereo Tool.

Even if sending metadata would block Stereo Tool for a moment (I haven't checked yet if it does) that shouldn't cause an issue since there's enough buffering available to catch up afterwards. So I'm not sure if this is the issue. But please first tell me if Stereo Tool and the crossfade plugin are both running as plugins in the same program.
I use foobar2000 for playing music, and no I have Stereo Tool standalone between virtual audio cables so not in the same program with the plugin.

Foobar2000 has a plugin also for outputting artist and title info into a text file, so Stereo Tool uses that to get it's data. Just curious now how often does it check the text files?


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu May 26, 2022 2:57 pm 

Joined: Sun Feb 03, 2013 2:39 pm
Posts: 320
Quote:
Quote:
  1. The Winamp version sometimes hangs (buffers?) when a new instance is started.
  2. Had an error message that a device wouldn't support 48kHz (it does) when opening a 2nd instance once, though everything worked fine. Cannot reproduce anymore.
  3. Old 'Flat frequency response' was removed from settings file. Just mentioning it in case it's an oversight and not intentional.
  4. Sound is different (louder, more mids) with tested profiles. Still investigating what's the cause.
We have an automatic test process and compared all the built-in presets... So this would be very strange. Do you have a specific preset in which this happens, and a description of steps to reproduce it?
After a quick test seems to be back to normal with 9.91b11.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu May 26, 2022 8:38 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10579
Quote:
Quote:
What player are you using, and is Stereo Tool running inside it? Because a crossfading plugin can also cause weird issues if it's in the same group of plugins as Stereo Tool.

Even if sending metadata would block Stereo Tool for a moment (I haven't checked yet if it does) that shouldn't cause an issue since there's enough buffering available to catch up afterwards. So I'm not sure if this is the issue. But please first tell me if Stereo Tool and the crossfade plugin are both running as plugins in the same program.
I use foobar2000 for playing music, and no I have Stereo Tool standalone between virtual audio cables so not in the same program with the plugin.

Foobar2000 has a plugin also for outputting artist and title info into a text file, so Stereo Tool uses that to get it's data. Just curious now how often does it check the text files?
It checks it multiple times per second. Can you try if you also get a dropout if you change the playing now file? Just to rule out some interference from something else (no idea what that could be, but getting these dropouts isn't normal).

Oh and just to make sure: Is that file on a local drive or on some shared drive from another system?


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu May 26, 2022 9:52 pm 
User avatar

Joined: Thu Apr 07, 2011 2:37 am
Posts: 148
Location: Napier, New Zealand
Quote:
Oh! You're right! Wow... I think I changed some default values at some point, not realizing that this would cause side effects in the not-stand-alone versions. Fixing it now, next beta should be ok again.
Thanks Hans!
Edit: Yes, both the Mic being opened and the Delossifier nuking Bass Exciter are fixed in 011, thanks!!

_________________
I just use ST Winamp to listen to music.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Fri May 27, 2022 5:39 am 

Joined: Sat Oct 14, 2017 3:31 am
Posts: 77
Hi all,
I might not even need the metadata on Windows fixed that much, I'm attempting to set up Liquidsoap with StereoTool using pipe method/code in the Liquidsoap script file, on a VPS.
However, Liquidsoap gives me an error when I try starting it.
" [mp3float @ 0x7f4788020640] Could not update timestamps for skipped samples. "
Do you know what that means? LOL Liquidsoap works fine when I comment out the "pipe" stuff from the file for Stereo Tool. But that defeats the point, since Liquidsoap doesn't have much in the way of audio processing.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Tue May 31, 2022 11:23 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10579
Quote:
I tried making a bug report topic last week but it never showed up. The labels in Spectral Hole Filler to Never or Always generate highest frequencies (via extreme tweaker) are reversed. Choosing "Never" rebuilds the frequencies, confirmed by the output spectrum and external recording software.
Whoops. Confirmed and fixed. The conversion from old settings to new settings was correct if you look at the names, so I've swapped the behavior to match the description. Anyone who set this up in 9.90 might need to flip this setting.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Tue May 31, 2022 1:36 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10579
Quote:
Ultimate GUI bug:
Legacy AGC > Press 'Hear' > Compressor in same AGC > Press 'Hear'.
Wooh. That's... insane. And it appears to happen any time I enable multiple "Hear"'s, regardless which ones.

Edit: Solved. Some line of code was changed and we all don't remember why. I've restored the old code and it works again. VERY odd.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Tue May 31, 2022 1:42 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10579
Quote:
Hi all,
I might not even need the metadata on Windows fixed that much, I'm attempting to set up Liquidsoap with StereoTool using pipe method/code in the Liquidsoap script file, on a VPS.
However, Liquidsoap gives me an error when I try starting it.
" [mp3float @ 0x7f4788020640] Could not update timestamps for skipped samples. "
Do you know what that means? LOL Liquidsoap works fine when I comment out the "pipe" stuff from the file for Stereo Tool. But that defeats the point, since Liquidsoap doesn't have much in the way of audio processing.
First to make sure, since it says mp3float, what you're piping through Stereo Tool is 16-bit stereo WAV, correct? Not MP3? Because that won't work, and will probably cause detection of corrupt MP3 packets on the other end.


Top
   
 Post subject: Re: Stereo Tool 9.90
PostPosted: Thu Jun 02, 2022 3:40 pm 

Joined: Sat Oct 14, 2017 3:31 am
Posts: 77
Not sure... I'm just using the command line version of ST with Liquidsoap's pipe command.
"radio = mksafe(pipe(data_length=0, replay_delay=1.5, restart_on_error = true, process='/home/.../stereo_tool - - -s /home/.../Preset.sts -q -k "<xxxxxxx>"',radio))"

I haven't purchased the program yet, so deleted the "-k "<xxxxxxx>"". Is it supposed to be there?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 50 posts ]  Go to page Previous 1 2 3 4 5

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited