All times are UTC+02:00




Post new topic  Reply to topic  [ 193 posts ]  Go to page Previous 17 8 9 10 1120 Next
Author Message
PostPosted: Thu Jan 20, 2022 9:43 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10537
BETA018 is available. AES67 is now supported in all builds (Linux/Mac/Pi). And there's a new stereo effect (L-R Phase shift).

To people in the Netherlands: If you're looking for the Veronica early 1990s stereo effect, this is that (if you combine it with a strong boost of the stereo). (Note to others: This effect in combination with a strong boost of the stereo will given an effect where if you switch over to mono, you loose a LOT of audio - that was also the case with Veronica in the 1990s.)

I hope to be able to post a new Enterprise beta tomorrow, after a big code rewrite which makes things a lot easier. (Among others, this will finally offer separate synchronization for both inputs.)


Top
   
PostPosted: Thu Jan 20, 2022 10:43 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3952
"Limit phase difference" Everything under 169 deg introduces some strange sounds on some tracks. Same sound on 'diff' (HD). Also i think i hear it only on right channel.
One example, Fisher - Losing it.

_________________
control point


Top
   
PostPosted: Fri Jan 21, 2022 4:44 pm 

Joined: Fri Nov 23, 2012 4:34 pm
Posts: 207
Listening to the Bass Exciter with difference enabled: changing the 'Generate bass above' slider seems to do something odd.
Seems to disable difference, clicking 'Block on startup' seems to help somehow?? Is something buggy here?


Top
   
PostPosted: Fri Jan 28, 2022 1:30 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10537
Quote:
Listening to the Bass Exciter with difference enabled: changing the 'Generate bass above' slider seems to do something odd.
Seems to disable difference, clicking 'Block on startup' seems to help somehow?? Is something buggy here?
Hi, no, it takes time to calculate new graphs when the setting are changed. If we do that at once (blocking) the new data is immediately there, but you might get sound card buffer underruns, especially on slower hardware or if your buffers are very small. So, we typically perform the calculation spread out over time. The filer is disabled temporarily until the calculation is finished.


Top
   
PostPosted: Fri Jan 28, 2022 1:34 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10537
BETA021 posted

We've done a quite massive redesign of the I/O layer for the Enterprise version of Stereo Tool. I just found a bug in it, so I'm not posting it yet (probably tomorrow), but some of these changes also affect the non-Enterprise version.

We have made the selection of Wasapi/KS/MME vs ASIO vs AES67 easier: Instead of having to enable the 1st ASIO channel to enable ASIO and having an AES67 switch which overrules both Wasapi etc *and* ASIO, we now have a single pulldown to select what you want to use. This should be much clearer, and it's also simpler in the code.

This does mean that we need to convert the old settings to the new ones, which might contain bugs. And the behavior itself is rewritten which may also contain bugs. We haven't seen any yet... but please let me know if you see *anything* weird when upgrading to this new beta.


Edit: The Winamp version crashes... looking into it now. Stand alone should be fine, the others might not be.
Edit: We were trying to upgrade the ASIO/Livewire etc setting for parameters that don't exist in the plugin versions. Solved, but for now only the stand alone versions work.


Top
   
PostPosted: Fri Jan 28, 2022 4:49 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10537
Quote:
"Limit phase difference" Everything under 169 deg introduces some strange sounds on some tracks. Same sound on 'diff' (HD). Also i think i hear it only on right channel.
One example, Fisher - Losing it.
Ooh! Wow. Deep inside a calculation there was a + that should have been a *. Now that that is solved, almost all of the filters inside Stereo Image sound way better!


Top
   
PostPosted: Fri Jan 28, 2022 4:56 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 195
Location: Utah, USA
Quote:
Quote:
"Limit phase difference" Everything under 169 deg introduces some strange sounds on some tracks. Same sound on 'diff' (HD). Also i think i hear it only on right channel.
One example, Fisher - Losing it.
Ooh! Wow. Deep inside a calculation there was a + that should have been a *. Now that that is solved, almost all of the filters inside Stereo Tool sound way better!
Since that’s a huge fix, would you kindly also release an updated declipper plugin soon?

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Fri Jan 28, 2022 4:57 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10537
Quote:
Quote:
Quote:
"Limit phase difference" Everything under 169 deg introduces some strange sounds on some tracks. Same sound on 'diff' (HD). Also i think i hear it only on right channel.
One example, Fisher - Losing it.
Ooh! Wow. Deep inside a calculation there was a + that should have been a *. Now that that is solved, almost all of the filters inside Stereo Tool sound way better!
Since that’s a huge fix, would you kindly also release an updated declipper plugin soon?
Sorry, typo... I meant inside Stereo Image.. :(


Top
   
PostPosted: Fri Jan 28, 2022 5:09 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 195
Location: Utah, USA
Quote:
Quote:
Quote:


Ooh! Wow. Deep inside a calculation there was a + that should have been a *. Now that that is solved, almost all of the filters inside Stereo Tool sound way better!
Since that’s a huge fix, would you kindly also release an updated declipper plugin soon?
Sorry, typo... I meant inside Stereo Image.. :(
Gotcha!

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Fri Jan 28, 2022 9:05 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3952
I don't know since when is this, but this is huge bug.
Both multibands does not output same as on "hear" button. Idk about compressors but only using limiters. "Hear" is ok, but output is not. Output is wrongly different.

Also there is bug in multiband clippers. OFF and +35,92dB (wich is max) are totally different in level and should be same.

_________________
control point


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 193 posts ]  Go to page Previous 17 8 9 10 1120 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited