All times are UTC+02:00




Post new topic  Reply to topic  [ 94 posts ]  Go to page Previous 1 2 3 4 5 610 Next
Author Message
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 5:06 pm 

Joined: Thu Jan 15, 2015 11:19 am
Posts: 105
I've installed the new build and did a video capture. Where shall I send it? It's close to 4 MB in size.


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 5:20 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Quote:
I've installed the new build and did a video capture. Where shall I send it? It's close to 4 MB in size.
So it's still doing the same thing? That's really problematic, the old PortAudio version had bugs that were fixed in the latest build, so going back to the old one isn't really an option...

Please send it to hans@thimeo.com, or upload it to something like WeTransfer. (Note: Our normal support email address is support@thimeo.com, but I'm not sure that the attachment will arrive there properly).


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 5:33 pm 

Joined: Wed Nov 20, 2013 6:42 pm
Posts: 53
I did some quick testing on the 64 bit version and it works better for me. There are some strange bugs in that build. Switching between presets under Web/DAB/HD, Analog Pleasure Deluxe is stable. Switching to Studio One, I get a GUI error and and warning about Sync I/O for sound cards which I have turned off. Things play normally for a few seconds then every filter past the noise gate stops working and goes black. Returning to Analog Pleasure Deluxe fixes everything. Other presets under Web/DAB/HD turn on MPX. I understand it is a test build.


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 5:40 pm 

Joined: Wed Nov 08, 2017 3:16 pm
Posts: 98
Quote:
Quote:
I've installed the new build and did a video capture. Where shall I send it? It's close to 4 MB in size.
So it's still doing the same thing? That's really problematic, the old PortAudio version had bugs that were fixed in the latest build, so going back to the old one isn't really an option...

Please send it to hans@thimeo.com, or upload it to something like WeTransfer. (Note: Our normal support email address is support@thimeo.com, but I'm not sure that the attachment will arrive there properly).
can you quote the bugs in the old version of portaudio ?
edit: nevermind - https://github.com/PortAudio/portaudio/ ... 0_20210307


Last edited by EliteData on Wed May 12, 2021 10:06 pm, edited 1 time in total.

Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 5:58 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Quote:
I did some quick testing on the 64 bit version and it works better for me. There are some strange bugs in that build. Switching between presets under Web/DAB/HD, Analog Pleasure Deluxe is stable. Switching to Studio One, I get a GUI error and and warning about Sync I/O for sound cards which I have turned off. Things play normally for a few seconds then every filter past the noise gate stops working and goes black. Returning to Analog Pleasure Deluxe fixes everything. Other presets under Web/DAB/HD turn on MPX. I understand it is a test build.
This is indeed based on code that's very much "in flux" at the moment, the parameter architecture is being redesigned. I hadn't really tested it yet. Anyway, does your first remark, "I did some quick testing on the 64 bit version and it works better for me", mean that the PortAudio I/O issues appear to be resolved?


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 6:14 pm 

Joined: Wed Nov 20, 2013 6:42 pm
Posts: 53
I've been testing by listening to music through it. Better means it runs longer before the audio garbles. I'm going to load it on another computer with a simple audio setup and try that.


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 6:18 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Quote:
I've been testing by listening to music through it. Better means it runs longer before the audio garbles. I'm going to load it on another computer with a simple audio setup and try that.
I just scrolled up to see what you wrote before, did 9.63 do it as well, or was 9.63 perfect, 9.70 bad and this in between?


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 6:55 pm 

Joined: Wed Nov 20, 2013 6:42 pm
Posts: 53
I can't be sure. It can take a long time for the problem to show up. After I finish testing with the new build, I'll go back and do a long term test with 9.63


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 8:12 pm 

Joined: Wed Nov 20, 2013 6:42 pm
Posts: 53
Sorry for the hold up, but now I can say with confidence that 9.70 beta 1 has fixed my I/O problem.

Thank you, Hans.


Top
   
 Post subject: Re: Stereo Tool 9.70
PostPosted: Wed May 12, 2021 8:21 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10245
Quote:
Sorry for the hold up, but now I can say with confidence that 9.70 beta 1 has fixed my I/O problem.

Thank you, Hans.
Ok. In that case, I have a suspicion that there might be some settings that I can change to fix the PortAudio issue, instead of having to go back to the old version. Apparently the changes that I made in 9.70, which I reverted here, caused at least some of the problems. Some of the settings were set to "undefined" ("let PortAudio figure out what's right") only in 9.70 - but some have *always* been set to that. So, for the next build I'm going to make some changes where I take full control of what happens from Stereo Tool.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 94 posts ]  Go to page Previous 1 2 3 4 5 610 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited