All times are UTC+02:00




Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 18 9 10 11 1215 Next
Author Message
PostPosted: Sun Dec 16, 2018 12:53 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
Quote:
Were you doing something special or did this happen out of the blue? I found the line of code that must have caused it but it doesn't make much sense to me yet. It would be way more logical if you had just switched between compressor modes for example. (But then you wouldn't have noticed the hiccup).
Only thing changed in this session is to turn on Immersive base, then about an hour later relocate it from before AGC to after AGC. It was running this way for about 30mins, popped up, I grabbed a copy of it to send to you and then acknowledged it.
Quote:
O, and has this ever happened before/how long was it running, has it happened since. I'm trying to figure out if this is something that's new in this build (which is unlikely because I haven't touched the compressor code in quite a while) or something that happens very very occasionally and might have been there for a long time already.
First time I have seen it. Here are the last couple of lines of the logfile -:

EXCEPTION OCCURRED IN release_ss: ss_inuse[index]
EXCEPTION OCCURRED IN ProcessingChain Thread (Exception 0xc0000005 at address 0x7ff60b8554da, read/write=1, r/w location=0x7a80). Offset-info: 0x7ff60bdcd809
---
EXCEPTION OCCURRED IN release_ss: index >= 0 && ss[index] == s
---
EXCEPTION OCCURRED IN ProcessingChain Thread (Exception 0xc0000005 at address 0x7ff76ce6492e, read/write=0, r/w location=0x0). Offset-info: 0x7ff76fbba2b9


The first one I have multiple entries for before that one (same offset, different address) but I do not know how old these are...

EXCEPTION OCCURRED IN ProcessingChain Thread (Exception 0xc0000005 at address 0x7ff60b8554da, read/write=1, r/w location=0x8780). Offset-info: 0x7ff60bdcd809

Could we add a date/time stamp to the log file entries perhaps?

Rossco
That might indeed be useful, but ---- indicates the first message since a restart so there is only this one message apparently. :(


Top
   
PostPosted: Tue Dec 18, 2018 10:03 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Stereo Tool 9.12 BETA018

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-018.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 12-018.exe
VST 2: http://www.stereotool.com/download/vst_ ... 12-018.dll
VST 3: http://www.stereotool.com/download/vst_ ... 2-018.vst3

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-018.exe
VST 2: https://www.stereotool.com/download/vst ... 12-018.dll
VST 3: https://www.stereotool.com/download/vst ... 2-018.vst3


CHANGES:
  • AVX2 support: Performance improvement on Intel Core i3/5/7 4000+ series when using Windows 7 SP1+/Windows 8/Windows 10
  • Stereo Tool: Measure effect of EstimateMath defines, try to remove - Not needed
  • Stereo Tool: Get rid of #ifdef SSE2 in OldSamples
  • Update Mathijs, Wes, Bojcha presets


    OLD CHANGES:
  • RDS: Add EON, via GUI and UECP
  • IB Hear function didn't work correctly if IB was moved
  • Fixed reported crash
  • Presets DCM and Cerulean, Magic Gold and Paul: Check BS412 levels. And update Cerulean to 1f
  • Update Wes' and Bojcha's preset
  • Immersive Bass HPF output not working correctly
  • Immersive Bass HPF input for cleaner sound ? - Difficult to do, doesn't appear to do a lot anyway.
  • Change Advanced Clipper for cleaner voices (less IMD). Very slightly higher CPU load.
  • Preset add Wes, Matt
  • Made Immersive Bass movable (before Auto EQ, before AGC, after AGC - before it was always before AGC).
  • Is VST3 ok in vMIX after the latest build? - Should be, works here, and code is more logical.
  • Immersive bass: Removed protection to not add too much again. It didn't have much effect, caused artifacts, and different compressor settings can give a very similar effect.
  • Remove MicroMPX startup logging in Stereo Tool/SST if not running, and put log file in user directory.
  • Linux MicroMPX version (32 bit)
  • Linux MicroMPX version (64 bit)
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • RDS: RT end at \n
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.



    TODO:
  • Stereo Tool: All builds now run on a Pentium 3 :shock: - no separate builds needed anymore...
  • Stereo Tool/SST: Disable MicroMPX if there's not at least SSE2
  • Stereo Tool: Kill off old SSE builds
  • Remove SSE2 check from installers
  • Test MicroMPX performance with new gcc on pi - 2% improvement
  • WatchCat GUI glitch Should be ok, waiting for testing
  • Bojcha's 2-stage bass clipper protection - Advanced Clipper will probably sound warmer, cleaner, punchier and louder with this
  • Remove AVX switch
  • WatchCat on Mac doesn't work
  • Release
    -
  • Clearer split between normal and advanced RDS features
  • Declipper cleanup L-R phase artifacts, maybe also width.
  • Can you please check Pre-Limiter used with Normal limit making some strange effect with thresh under 3-4dB at 64 bands or less.
  • Check new installer script
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian
  • VST for DJB
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
PostPosted: Tue Dec 18, 2018 9:54 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 154
Location: Utah, USA
Got this error:
Running on Intel Core 2 Duo E8600 Win10 Enterprise x64
This is the DSP version Beta 18:

-also: Deleted the .ini file as well and am running default Stargate Preset.


Attachments:
sterror.PNG
sterror.PNG [ 10.91 KiB | Viewed 2102 times ]

_________________
America's Country
Hot Country Hits!
Top
   
PostPosted: Wed Dec 19, 2018 9:14 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Stereo Tool 9.12 BETA019

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-019.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 12-019.exe
VST 2: http://www.stereotool.com/download/vst_ ... 12-019.dll
VST 3: http://www.stereotool.com/download/vst_ ... 2-019.vst3 BUILD FAILED

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-019.exe
VST 2: https://www.stereotool.com/download/vst ... 12-019.dll
VST 3: https://www.stereotool.com/download/vst ... 2-019.vst3 BUILD FAILED


CHANGES:
  • Stereo Tool: All builds now run on a Pentium 3 :shock: - no separate builds needed anymore...
  • Stereo Tool/SST: Disable MicroMPX if there's not at least SSE2
  • Stereo Tool: Kill off old SSE builds
  • Remove SSE2 check from installers
  • Test MicroMPX performance with new gcc on pi - 2% improvement


    OLD CHANGES:
  • AVX2 support: Performance improvement on Intel Core i3/5/7 4000+ series when using Windows 7 SP1+/Windows 8/Windows 10
  • Stereo Tool: Measure effect of EstimateMath defines, try to remove - Not needed
  • Stereo Tool: Get rid of #ifdef SSE2 in OldSamples
  • Update Mathijs, Wes, Bojcha presets
  • RDS: Add EON, via GUI and UECP
  • IB Hear function didn't work correctly if IB was moved
  • Fixed reported crash
  • Presets DCM and Cerulean, Magic Gold and Paul: Check BS412 levels. And update Cerulean to 1f
  • Update Wes' and Bojcha's preset
  • Immersive Bass HPF output not working correctly
  • Immersive Bass HPF input for cleaner sound ? - Difficult to do, doesn't appear to do a lot anyway.
  • Change Advanced Clipper for cleaner voices (less IMD). Very slightly higher CPU load.
  • Preset add Wes, Matt
  • Made Immersive Bass movable (before Auto EQ, before AGC, after AGC - before it was always before AGC).
  • Is VST3 ok in vMIX after the latest build? - Should be, works here, and code is more logical.
  • Immersive bass: Removed protection to not add too much again. It didn't have much effect, caused artifacts, and different compressor settings can give a very similar effect.
  • Remove MicroMPX startup logging in Stereo Tool/SST if not running, and put log file in user directory.
  • Linux MicroMPX version (32 bit)
  • Linux MicroMPX version (64 bit)
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • RDS: RT end at \n
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.



    TODO:
  • Remove AVX switch
  • WatchCat GUI glitch Should be ok, waiting for testing
  • Fix AVX/SSE switch
  • Add import/export of IB
  • Check Basstardizer DIFF mode
  • Update Dutch Chocolate Moose preset
  • Add 2-stage bass clipper in advanced clipper
  • WatchCat on Mac doesn't work -> Installer issue, check before releasing
  • Release
    -
  • Clearer split between normal and advanced RDS features
  • Declipper cleanup L-R phase artifacts, maybe also width.
  • Can you please check Pre-Limiter used with Normal limit making some strange effect with thresh under 3-4dB at 64 bands or less.
  • Check new installer script
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian
  • VST for DJB
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
PostPosted: Wed Dec 19, 2018 2:17 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 154
Location: Utah, USA
This one still comes up as Beta 18. With this slightly different error:


Attachments:
sterror1.PNG
sterror1.PNG [ 4.74 KiB | Viewed 1996 times ]

_________________
America's Country
Hot Country Hits!
Top
   
PostPosted: Wed Dec 19, 2018 2:27 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
This one comes up as Beta 18. With this slightly different error:
Ow. I was afraid that this would happen (but didn't really expect it).

Please answer a few questions:
1. Which OS are you using?
2. What *exact* CPU is in it?
3. Is the GUI still usable? If so, please go to Configuration, set it to "Extreme Tweaker" mode, and check (bottom right) what it says under "CPU features".

It might (should) help to change that to a lower setting.


Edit: Never mind. Am seeing it here too on an old XP install. Searching for the cause now....


Top
   
PostPosted: Wed Dec 19, 2018 3:09 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 154
Location: Utah, USA
Hans,

Running on Intel Core 2 Duo E8600 Win10 Enterprise x64

I can't clear the error. It keeps repeating.

Thanks,

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Wed Dec 19, 2018 3:35 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10028
Quote:
Hans,

Running on Intel Core 2 Duo E8600 Win10 Enterprise x64

I can't clear the error. It keeps repeating.

Thanks,
Yes. It appears that the compiler has done things that I didn't expect. Am trying to figure out now how to avoid that from happening. Debug version is ok, release is not, on older systems/OS's...

Edit: Been googling and there doesn't appear to be a good (reliable) solution for this issue. It's a real fringe case of compiler optimization (mis)behavior. Ugh. Will try out some things later today.


Top
   
PostPosted: Wed Dec 19, 2018 4:45 pm 

Joined: Sun Feb 03, 2013 2:39 pm
Posts: 312
DSP beta 19 & 20 are actually the same as beta 18 (bit identical).


Last edited by \_/ on Thu Dec 20, 2018 8:02 am, edited 1 time in total.

Top
   
PostPosted: Wed Dec 19, 2018 10:57 pm 

Joined: Sun May 18, 2008 10:10 am
Posts: 74
Hans

First of all Season's Greetings

I've just installed the ß19 and noticed that when ST is dispalyed that ß18 is seen on the top


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 18 9 10 11 1215 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited