All times are UTC+02:00




Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 19 10 11 12 1315 Next
Author Message
PostPosted: Wed Dec 19, 2018 11:27 pm 

Joined: Sun Feb 12, 2017 10:22 pm
Posts: 15
Basstardizer 'Difference' seems to be broken. Not sure if the whole basstardizer is not working anymore, but selecting 'Difference' doesn't give any output...


Top
   
PostPosted: Thu Dec 20, 2018 3:15 pm 

Joined: Fri Feb 19, 2016 9:28 pm
Posts: 4
Quote:
This one still comes up as Beta 18. With this slightly different error:
Same Issue!

I've disabled the Noise-Gate and the Stereo-Amplifier.

Now it works..


Top
   
PostPosted: Thu Dec 20, 2018 3:28 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 154
Location: Utah, USA
Quote:
Quote:
This one still comes up as Beta 18. With this slightly different error:
Same Issue!

I've disabled the Noise-Gate and the Stereo-Amplifier.

Now it works..
How did you get past the errors? I couldn't get around it to even try.

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Thu Dec 20, 2018 10:49 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10027
Quote:
Hans,

Running on Intel Core 2 Duo E8600 Win10 Enterprise x64

I can't clear the error. It keeps repeating.

Thanks,
I think I found a workaround for what appears to be a compiler bug. The good news is: The new version is about 5% faster than before if you have a modern CPU. There should be no difference on older CPU's (the ones that gave this error message). I still need to verify that myself here with the workaround code, the first numbers are looking ok but I need to run a full release build. As a "bonus", Stereo Tool *might* now also run on very old hardware (Pentium 2 and 3 - not tested, since I don't have one anymore).

Anyway, I expect to have a new build tomorrow morning.


Top
   
PostPosted: Fri Dec 21, 2018 12:59 am 
User avatar

Joined: Mon Nov 23, 2015 12:39 am
Posts: 32
Quote:
As a "bonus", Stereo Tool *might* now also run on very old hardware (Pentium 2 and 3 - not tested, since I don't have one anymore).
Probably not the Pentium 2 unless you fallback to plain old x87 FPU code, as it didn't have SSE yet (Pentium 3 Katmai's were the first to have it, at least my 500 MHz one does). Equivalent "first SSE" chip for AMD would be the Athlon XP line up (or that mobile Athlon with Palomino core). Both meaningless for any modern audio processor.


Top
   
PostPosted: Fri Dec 21, 2018 3:28 am 

Joined: Mon Feb 04, 2013 11:25 pm
Posts: 153
ST use to play well on my Core Duo 2 quad 266 .


Top
   
PostPosted: Fri Dec 21, 2018 10:12 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 10027
Stereo Tool 9.12 BETA021

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-021.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 12-021.exe
VST 2: http://www.stereotool.com/download/vst_ ... 12-021.dll
VST 3: http://www.stereotool.com/download/vst_ ... 2-021.vst3

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 12-021.exe
VST 2: https://www.stereotool.com/download/vst ... 12-021.dll
VST 3: https://www.stereotool.com/download/vst ... 2-021.vst3


CHANGES:
  • Fixed AVX/SSE switch (compiler bug workaround) - works on older systems/OS's again. About 5% CPU load reduction on newer systems.


    OLD CHANGES:
  • Stereo Tool: All builds now run on a Pentium 3 :shock: - no separate builds needed anymore...
  • Stereo Tool/SST: Disable MicroMPX if there's not at least SSE2
  • Stereo Tool: Kill off old SSE builds
  • Remove SSE2 check from installers
  • Test MicroMPX performance with new gcc on pi - 2% improvement
  • AVX2 support: Performance improvement on Intel Core i3/5/7 4000+ series when using Windows 7 SP1+/Windows 8/Windows 10
  • Stereo Tool: Measure effect of EstimateMath defines, try to remove - Not needed
  • Stereo Tool: Get rid of #ifdef SSE2 in OldSamples
  • Update Mathijs, Wes, Bojcha presets
  • RDS: Add EON, via GUI and UECP
  • IB Hear function didn't work correctly if IB was moved
  • Fixed reported crash
  • Presets DCM and Cerulean, Magic Gold and Paul: Check BS412 levels. And update Cerulean to 1f
  • Update Wes' and Bojcha's preset
  • Immersive Bass HPF output not working correctly
  • Immersive Bass HPF input for cleaner sound ? - Difficult to do, doesn't appear to do a lot anyway.
  • Change Advanced Clipper for cleaner voices (less IMD). Very slightly higher CPU load.
  • Preset add Wes, Matt
  • Made Immersive Bass movable (before Auto EQ, before AGC, after AGC - before it was always before AGC).
  • Is VST3 ok in vMIX after the latest build? - Should be, works here, and code is more logical.
  • Immersive bass: Removed protection to not add too much again. It didn't have much effect, caused artifacts, and different compressor settings can give a very similar effect.
  • Remove MicroMPX startup logging in Stereo Tool/SST if not running, and put log file in user directory.
  • Linux MicroMPX version (32 bit)
  • Linux MicroMPX version (64 bit)
  • What does the new Immersive Bass display show? Either remove it, or add it to bottom display as well.
  • Immersive bass: Added protection to not add it if it's already there (can be defeated, for now, for testing).
  • Updated Paul Thompson's Breaking Dreams Loud preset - now uses Immersive Bass.
  • Finish Immersive Bass: Add better HPF, tilt, non-lossy adder, update name to Immersive Bass, updated presets.
  • RDS: Remove dynamic memory allocations when the PS/RT/PTYN strings are modified. Pre-allocate enough memory once.
  • RDS UECP: Add support for multiple UECP encoders with different port addresses.
  • RDS UECP: Add support for multiple site/encoder addresses.
  • Add Mathijs' new preset
  • VST3 plugin doesn't work in vMIX - fixed something...
  • Added new bass filter (not yet finished)
  • VST3 64 bit plugin fixed (32 is probably still broken)
  • RDS: UECP: Site and Encoder address were swapped. Fixed, not tested.
  • Optimize Stokkemask post filter
  • CPU load 100% in web thread Linux?
  • No ASIO asserts in debug mode
  • Group 15B also send 4x on TA start (was only doing it on end).
  • Added odd/even harmonics selection in Basstardizer (was only odd before).
  • Nicer input sound card open error handling (softer beeps, retrying and restarting added).
  • RDS: Add PIN to interface
  • VST3 plugin
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • No PIN EWS
  • Look at text alignment
  • Split RDS features in standard and advanced RDS (EON, AF method B, ECC, EWS, ODA - TMC etc)
  • RDS AF method B
  • RDS AF method B via UECP Probably done but can't test it now.
  • RDS: RT end at \n
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.



    TODO:
  • Check Basstardizer DIFF mode -> Checked, works fine now, probably an issue with the optimization error in previous beta's
  • Add import/export of IB
  • Fix Mac build
  • WatchCat GUI glitch Should be ok, waiting for testing
  • Add 2-stage bass clipper in advanced clipper
  • Update Dutch Chocolate Moose preset
  • WatchCat on Mac doesn't work -> Installer issue, check before releasing
  • "Relative adjustment" too low warning
  • Release
    -
  • Clearer split between normal and advanced RDS features
  • Declipper cleanup L-R phase artifacts, maybe also width.
  • Can you please check Pre-Limiter used with Normal limit making some strange effect with thresh under 3-4dB at 64 bands or less.
  • Check new installer script
  • MicroMPX: Add manual (how to setup)
  • Glitch when turning Bypass off
  • 1024x600 screen misses VU meters
  • AAX plugin
  • Right-click tray icon bypass is bad
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian
  • VST for DJB
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


I know, yet another bass filter. Mathijs was complaining that the bass still didn't sound right. It lacked warmth. We started experimenting, and at some point his reponse was "That's it!". So, we've worked on adding that specific bass. Somehow, I've never missed it, but when I listened to it in my car, I suddenly had the feeling that I was "bathing in bass". Hence the name "Immersive Bass". Interestingly, it is less noticable on my monitor speakers in our office.

Earlier filters such as Basstardiser now sound "hollow" in comparison, and I would describe this new bass as "warm". The new "Dutch Chocolate Moose" preset is using it. Still work in progress, but it's close to Dutch Moose, with more of "that" bass.


Top
   
PostPosted: Fri Dec 21, 2018 2:23 pm 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 154
Location: Utah, USA
Working great, so far! Thanks Hans!

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Fri Dec 21, 2018 8:31 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3558
beta21 does not working good on WinXP. So be careful. Huge CPU load!

_________________
control point


Top
   
PostPosted: Fri Dec 21, 2018 10:54 pm 
User avatar

Joined: Thu Jul 01, 2010 12:42 pm
Posts: 135
Location: Australia
Beta019 working fine in a production deployment now for several days, and wow doesn't it sound good!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 143 posts ]  Go to page Previous 19 10 11 12 1315 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited