All times are UTC+02:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Wed Nov 22, 2017 11:09 am 

Joined: Tue Aug 23, 2016 9:42 am
Posts: 36
Location: France
Hi everybody.
I'm trying to use Magic RDS to command Stereo Tool's integrated RDS. Magic RDS software is configured to read a remote website and look for the current song. Then it sends it as RT+. After 3 minutes, if the song hasn't changed (or if internet connection is lost), it displays a default radiotext message until a new song is found.
It works perfectly if I use a Pira RDS encoder. However, when used with Stereotool, RT+ is sent without any problem, but the default radiotext message is altered. For example, if the default message is " Magic default RadioText ", it will become " +00M-agic default RadioText ". Could it be due to switching between RT+ and "normal" radiotext ?
Any help would be appreciated !


Top
   
PostPosted: Wed Nov 22, 2017 2:16 pm 

Joined: Tue Aug 23, 2016 9:42 am
Posts: 36
Location: France
Oh by the way I have forgotten to say that I’m using 8.54. But I had the same problem with older versions.


Top
   
PostPosted: Fri Nov 24, 2017 3:43 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9385
Hm, I don't see it here (in 8.54) so I'm guessing it must somehow be related to how you setup MagicRDS. I don't see any RT+ settings in it?


Top
   
PostPosted: Fri Nov 24, 2017 3:53 pm 

Joined: Tue Aug 23, 2016 9:42 am
Posts: 36
Location: France
Hi Hans, thanks for taking time to answer. MagicRDS allows to use RT+ : http://www.pira.cz/rds/show.asp?art=guide_text_11
Actually RT+ is sent properly and decoded well by my receiver. Only problem is when coming back to normal Radiotext (stored in a local file), the +00 - string gets added. Do you want me to send my MagicRDS settings to you?


Top
   
PostPosted: Wed Nov 29, 2017 10:04 am 

Joined: Tue Aug 23, 2016 9:42 am
Posts: 36
Location: France
Ok so I’ve found a way to avoid the problem. I’ve modified the “static” normal radiotext so that it contains “ - “. This way, it is sent as a RT+ message and it is displayed correctly. For example : “TEST FM - The best radio” will be sent as Artist : TEST FM and Song : The best radio. It works fine but it would be nice if I could make it work without “cheating” like this.


Top
   
PostPosted: Mon Feb 26, 2018 11:40 am 

Joined: Tue Aug 23, 2016 9:42 am
Posts: 36
Location: France
Hi! I see you’ve been working on RDS recently. Did you have time to look at this problem ? Thanks a lot for your work !


Top
   
PostPosted: Tue Apr 03, 2018 4:28 pm 

Joined: Mon Dec 12, 2011 5:02 pm
Posts: 50
That is true, I can confirm that. If you have enabled RT+ in Magic RDS, +00 will show anytime you don't have separator.

Regards!


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited