All times are UTC+01:00




Post new topic  Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Jul 14, 2019 12:34 am 

Joined: Sun Sep 10, 2017 7:26 pm
Posts: 10
I'm using the Immersive Bass feature to "bring up" frequencies that are too deep for my speakers' natural frequency response. I understand this just produces harmonics from the lower frequencies, but hearing something is better than hearing nothing.

I have an input low pass of 36Hz and output high pass of 80Hz.

With the Stereo Tool CPU Quality set to 150%, Immersive Bass produces clean distortion-free harmonics that sound great. However, at 100% CPU Quality, the harmonics are twice as loud and very, very distorted.

Could we get a "HQ" button for the Immersive Bass feature so that it always produces a clean output?


Top
   
PostPosted: Sun Jul 14, 2019 3:12 am 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3480
No, i wanted same for Phase Linear HPF. Or everything or nothing.

_________________
control point


Top
   
PostPosted: Mon Jul 15, 2019 8:55 pm 

Joined: Sun Sep 10, 2017 7:26 pm
Posts: 10
Well this is a bug more than a feature request. The output is so dirty that it's unusable so really needs to be fixed.


Top
   
PostPosted: Tue Jul 16, 2019 3:35 am 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3480
Quote:
Well this is a bug more than a feature request. The output is so dirty that it's unusable so really needs to be fixed.
It's not bug, it works like that.

_________________
control point


Top
   
PostPosted: Tue Jul 16, 2019 11:55 am 

Joined: Sun Sep 10, 2017 7:26 pm
Posts: 10
What?

Have you tried listening to Immersive Bass with 100% quality vs 150%? The output actually _is_ unusable at 100%. It sounds like a fart. It's evidently not a "feature" to sound purposefully distorted when, at 150% quality, the output is entirely different.

1. Fix it
2. Disable it for <150% Quality


Top
   
PostPosted: Tue Jul 16, 2019 3:11 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3480
Quote:
What?

Have you tried listening to Immersive Bass with 100% quality vs 150%? The output actually _is_ unusable at 100%. It sounds like a fart. It's evidently not a "feature" to sound purposefully distorted when, at 150% quality, the output is entirely different.

1. Fix it
2. Disable it for <150% Quality
Yes, to me is always unusable.

_________________
control point


Top
   
PostPosted: Mon Aug 05, 2019 10:25 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9897
Ah, the issue here is the lowpass filter at 36 Hz. That's too low to do accurate filtering without being in 150% mode. At the default settings, 150% still sounds better, but the difference is a lot smaller. We could - as a workaround - automatically make the filter less steep at lower quality settings, to at least avoid the rumbling sounds that you otherwise get.


Top
   
PostPosted: Mon Aug 05, 2019 1:51 pm 

Joined: Sun Sep 10, 2017 7:26 pm
Posts: 10
Quote:
Ah, the issue here is the lowpass filter at 36 Hz. That's too low to do accurate filtering without being in 150% mode. At the default settings, 150% still sounds better, but the difference is a lot smaller. We could - as a workaround - automatically make the filter less steep at lower quality settings, to at least avoid the rumbling sounds that you otherwise get.
That sounds like a great plan! How can we make it happen?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited