All times are UTC+02:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Feb 26, 2019 12:32 pm 

Joined: Tue Feb 19, 2019 2:02 pm
Posts: 4
I trying to use the Stereo Tool version 9.23 (ARM 64bit) on an NanoPC-T3Plus board (http://wiki.friendlyarm.com/wiki/index. ... dware_Spec) that has a Samsung S5P6818 Octacore Arm A53 CPU and 2GB of RAM.
To run Stereo tool I use an Armbian OS (64bit Debian based).
In Stereo tool when I enable different modules, Multiband, AutoEQ, etc. etc. (simply by loading an available preset) I have a CPU load of around 45/50%. When enable Stereo Encoding on “FM transmitter” the CPU load goes to over 90% the “CPU Hiccup message appears” and the also audio output have hiccup. It’s normal the Stereo Encoding requires lot of CPU processing ?
I’ve migrate to Nano PC T3-Plus because on Raspberry Pi3+ I’ve the same problems but only with processing (without FM stereo encoding)..
I’ve hear about Stereo tool running on Raspberry Pi3+, but how works fine?? You can confirm that Stereo tool runs on Raspberry but with limitations (No FM stereo encoding, some modules disabled, etc. etc.)?

What are the hardware requisite to run Stereo Tools with complete processing, stereo and RDS coding, advanced clipper and also (optional) StokkeMask ?

Thank you in advance!


Top
   
PostPosted: Tue Apr 02, 2019 9:29 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9859
Hi,

Adding stereo or RDS encoding doesn't add a lot of CPU - but when you turn this on you also have to turn on FM processing, which requires oversampling on the final clippers. And the audio needs to be upsampled to 192 kHz. You might also have the composite clipper enabled (which will turn on as soon as the pilot is there).

I've been able to run a full FM preset, even with composite clipping, on the Pi, but I had to lower the quality to about 50-60%. And cooling is important, without some form of cooling I couldn't go anywhere near these numbers. (And at least on the Pi, once it gets hot, it throttles but doesn't seem to cool enough to stop throttling).

My suggestion is to set the Quality slider to 20% and Latency to 2048 (that helps A LOT compared to 4096, probably due to cache sizes). Then tweak your preset and try to make the CPU load as low as possible. Finally, increase it again.

Under CPU & Latency, make sure that you're using 3 (or 4, that doesn't really seem to matter) processing cores with no subthreads per channel, and enable "Ignore high frequencies" (that lowers the CPU load by about 20-30% for FM at 192 kHz).

Things to change to lower CPU load:
- Strictness under the clipper or composite clipper settings. Setting it lower helps a lot.
- Don't use Natural Dynamics or Delossifier. They are really heavy on ARM
- In the Declipper, set "Step size reduction" to 0.75. This has a small effect on audio quality but reduces the CPU usage of it by half.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited