All times are UTC+01:00




Post new topic  Reply to topic  [ 11 posts ]  Go to page 1 2 Next
Author Message
 Post subject: Output level creeping up
PostPosted: Sun Jul 22, 2018 8:09 pm 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
Newbie here.

I installed Stereo Tool to try and solve the problem of voices in films being too quiet compared to the background sound, and with AGC turned on it seems to do that pretty well.

But the problem I'm experiencing is that the output level creeps up over about 10-20 minutes, to the point where I get a lot of distortion. Clicking on the "restart sound card" button solves this temporarily, but it comes back again after 10-20 minutes.

This is visible in the blue outputs level bar on the right hand side of the sound card dialogue box. It creeps up from about 40-50% to about 80%.

Apart from turning on AGC which is off by default, I didnt change many settings in Stereo Tool.

I use the low latency output with the volume set to 96% which seems to be a default. Output volume is generally rather low.

Selecting different virtual cables as input and output (kernel streaming, wasapi, MME) doesnt seem to make any difference.

My system: Win 10 64 bit. Stereo Tool V9.01 stand-alone (same problem with V8.54). VB Virtual Cable, then tried VAC - same problem. Nvidia GTX1060 video card HDMI output.

Any suggestions appreciated.


Top
   
PostPosted: Mon Jul 23, 2018 4:54 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9500
Ow. Those meters aren't output level, but buffer usage.

If it creeps up this fast, then the VAC sample rate is very far off. Stereo Tool will compensate for that - upto a point. If it's too far off, it won't keep up. And when the buffer is too full, it starts to drop parts of the audio which will sound really bad.

Workaround (the actual issue is in VAC): In the input sound card settings, there's a "Synchronize to output" setting, with a speed slider (with a value that's by default 0.5%). Set that higher. 1%, maybe even 1.5...

Edit: If both VAC and VB Cable have this, it might instead be a problem in your actual sound card. That's rare - but it can happen.


Top
   
PostPosted: Mon Jul 23, 2018 6:02 pm 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
Thanks. I'll give that a try and report back.


Top
   
PostPosted: Wed Jul 25, 2018 7:47 am 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
I tried that setting but it didnt seem to make any difference at all. Thanks anyway.

Another thing I notice is that the "bypass" button doesnt seem to do anything, though turning the individual processes off does.

Anyway, at the moment I am testing some software called Breakaway which seems to do a similar job and which does not seem to have this problem. It is a lot less configurable though.


Top
   
PostPosted: Sat Jul 28, 2018 6:37 am 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
Breakaway introduced a load of problems of its own, mostly to do with it being impossible to turn the equaliser presets off: they were causing all sorts of strange sounds on some types of music. I only really want the compression/AGC functions anyway, so I removed that and am back with Stereo Tool which is still producing the same distortion problem after about 10-20 minutes of use.

I've tried increasing the synchronise slider to 1%, and 1.5% and also 2, 3, 4 and 5% without it having any apparent effect.

I also tried using ASIO4ALL, which seemed to install but Stereo Tool just kept giving ASIO error messages so I removed ASIO4ALL. Also ASIO4ALL seems to be years out of date and stuck in the Win7 era, as indeed are VB Cable and VAC.

I notice that there are several sample rate settings both in Stereo Tool and also in the Virtual Cable control panel (44.1, 48, 96 and more). And I also notice that I have three options of output sound card to select: WASAPI, Kernel Streaming and MME. Some of them show sample rate ranges after the name - such as 32-96 - but I still get sample rate error messages in Stereo Tool sometimes when switching outputs. (The output name changes on its own when I turn on the screen connected to my A/V amp, and I have to select the new name myself to get the sound back.)

To me it seems best to set all the options to the same sampling rate (ie 48) so as to avoid resampling, but what are the best output types and sample rate settings to use? I cant find any relevant instructions anywhere. I know that ASIO is supposedly the best option, but that doesnt appear to be possible.

Is there any possibility of introducing an optional automatic sound card restart function into Stereo Tool, that could be set to restart the sound card (say) every 10 minutes? Or is there any other way of doing this? I can put up with the very brief break in audio that this causes.

What I really dont understand is how a modern HDMI card from the biggest manufacturer could apparently have these faults. When used on its own, without virtual cables and audio enhancements tools, it works just fine without any distortion or glitches of any type. The only problem with that is that I have no way of getting uniform output from it, and the volume keeps jumping up and down according to the source material. :cry:
Is using the built-in SPDIF output on the motherboard (or fitting a sound card) the only alternative? Seems very backwards to me. I thought the whole point of HDMI was that it can handle everything involved in connecting to an amp and speakers and screen.


Top
   
PostPosted: Sun Jul 29, 2018 1:16 am 

Joined: Wed Nov 08, 2017 3:16 pm
Posts: 20
i had an issue similar to yours where the normal output buffer kept filling and emptying constantly.
the solution was to go into the sound properties and under "recording" for the device that is feeding the sound to ST, check "listen to this device on:" to a dummy or not used device.
since i use "stereo mix" instead of VB as the input to ST, my screen shot shows "stereo mix" being fed to VB (VB isnt being used and its volume is muted).
https://i.imgur.com/ir7BH8k.jpg


Top
   
PostPosted: Sun Jul 29, 2018 9:55 am 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
Thanks for that suggestion. I tried it and it made a small difference, but unfortunately it didnt solve the problem. I also tried unchecking the "listen to this device" box altogether but that didnt seem to do much either.

However a combination of the above, and increasing the size of the buffer, does mean that it fills up much more slowly, which also means that I need to restart the sound cards less often: perhaps every half hour.

So that's an improvement.


Top
   
PostPosted: Sat Aug 04, 2018 5:19 am 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
Progress. :)

It seems as though the problems I was experiencing may be related to the selection of the low latency output rather than the regular output, and to the volume levels.

I had selected the low latency output because watching streamed video over a browser offers no means of adjusting the audio delay, unlike when watching video files in a media player which has built-in delay adjustments.

I saw it mentioned many times in the documentation, and the help pop-ups, that volume settings and drive levels cannot cause distortion, and I took that at face value, but just yesterday I noticed that the volume level on the low latency output specifically says that it has to be set below a level that would cause spikes. So I have adjusted this and that has improved things.

When using the regular output there dont seem to be any buffer issues at all (the output blue bar stays rock steady at 50%), but as I mentioned this is not a solution when viewing streamed video in a browser. So I need to look into this more.


Top
   
PostPosted: Sat Aug 04, 2018 9:45 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9500
Ah!!!! Yes, the low latency output has no resampling or anything else - it's supposed to be used in ASIO mode on the same sound card as the input. Keeping the buffer constant adds latency.

For what you want, try if you can use ASIO. Even with the normal output, total input-to-output latency can be set as low as 16 ms. That should be low enough for watching video's. But things like VAC and VB Cable tend to add a lot of latency as well, so I'm not sure if that's going to work in the first place. (Well, if it was good enough with the low quality output, then normal output should be good as well, if you set the processing block size under "CPU & Latency" to 512).


Top
   
PostPosted: Sun Aug 05, 2018 7:15 pm 

Joined: Sat Jul 21, 2018 7:05 pm
Posts: 8
I did try ASIO again, and managed to get it partially working (the ASIO outputs did not work ever). But ASIO causes too many problems with other PC programmes so I removed it again.

So at the moment I am using the normal output in Stereo Tool, with the buffer set to 1000ms and the sync setting on the default of 1%. This seems to be working fine, and my media player can easily compensate for an audio delay of that length, so everything is in sync and there is no distortion and the buffer never seems to move from 50%. For playing back audio files and streaming audio the delay is not an issue at all, of course.

And when I want to stream video via a browser I just switch to the LQ Low Latency output. I dont do it very often and so it isnt much of a problem to restart the sound card from time to time if things go haywire.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 11 posts ]  Go to page 1 2 Next

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited