Stereo Tool

Feedback, questions, settings and more...
      Home         Download         Donate         Register         Forums         Help   
It is currently Wed Nov 22, 2017 2:49 am

All times are UTC+01:00




Post new topic  Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Fri Jun 16, 2017 7:12 pm 

Joined: Sun Mar 29, 2015 10:33 am
Posts: 16
ive noticed something i think should be considered.


every time i get the NAN Critical Error, my Bass Boost Meter freezes but everything else continues to operate normally.

HVZ this may be linked to the NAN Error ( im not a programmer but it is very noticeable every time it happens. BB Still works, but the Meter Freezes.


Top
   
PostPosted: Fri Jun 16, 2017 11:20 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9014
Is this with version 8.40? I haven't seen NAN errors in a long time..... 8.40 has code to recover from a NAN so it doesn't kill other filters.

Which version are you using exactly? Also is it the DSP or VST Zor stand alone, 32 or 64 bit?
And what CPU do you have?


Top
   
PostPosted: Sun Jun 18, 2017 1:14 am 

Joined: Mon Jan 11, 2016 9:28 am
Posts: 28
Hans, I haven't seen the NAN error on the processor at work (windows 64 bit standalone version), but I often get it on my Intel i5 laptop at home, that I use to program my presets with (Winamp plugin version).

I get it when I change presets a lot (to compare between them). I can't nail it down to something specific that causes it unfortunately.

I've also noticed with Version 8.40, that yes it recovers from the NAN error, but the volume output increases significantly, & the clipper goes from very little, to almost full scale (on the GUI meter). I then have to reboot Winamp, to get it working properly again.


Top
   
PostPosted: Sun Jun 18, 2017 1:16 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9014
Ok. In that case I must have missed part of what needs to be recovered. Can you see any other meter that's still at a wrong level when the volume is up? Are the multibands still functioning according to the meters?

I did just get a NAN here in the debugger, and fixed the cause of that (it was in the Delossifier). I don't *think* that this specific situation can occur outside of debug mode though.


Top
   
PostPosted: Mon Jun 19, 2017 6:10 am 

Joined: Mon Jan 11, 2016 9:28 am
Posts: 28
Quote:
Can you see any other meter that's still at a wrong level when the volume is up? Are the multibands still functioning according to the meters?

There doesn't seem to be as much indication on the mutli-band meters when the volume is up? i.e. the band meters don't come down as far, but i don't think there's a lot of difference, thus it's hard to tell how much effect this has on the multi-bands audio.

I use the de-esser too, & it peaks out after NAN recovery when the volume is up, when normally it's only about 1/3 to 1/2 way up.
The Bass clipper meter is slightly increased too, but not by much.

All other meters & levels seem to be as per normal.


Top
   
PostPosted: Tue Jun 20, 2017 1:19 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9014
I would expect meters to either be at their normal level, or completely full or completely empty. They might need some time to recover but after that this is what I would expect.


Top
   
PostPosted: Mon Jun 26, 2017 9:06 pm 

Joined: Sun Mar 29, 2015 10:33 am
Posts: 16
i was pre-840, now im running 840.


everything BUT the BB Meter would work just fine. the BB Meter would FREEZE in its last state at the moment the NAN Error dropped.


Sorry about information, it was DSP Winamp Plugin, Win10 x64 latest build.

IIRC it was 8.25 BETA 056 ......

i dont check for updates too often, i am now on 8.40


Specs:

i7 7700K ( 4.8 GHz Clock )
32GB DDR-4
ASUS TUF Z-270 Mark I mobo


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 7 posts ] 

All times are UTC+01:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited