All times are UTC+02:00




Post new topic  Reply to topic  [ 14 posts ]  Go to page 1 2 Next
Author Message
 Post subject: Stereo Tool 9.11 BETA
PostPosted: Sun Oct 21, 2018 3:43 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9741
Stereo Tool 9.11 BETA004

Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 11-004.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 11-004.exe
VST: http://www.stereotool.com/download/vst_ ... 11-004.dll

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 11-004.exe
VST: https://www.stereotool.com/download/vst ... 11-004.dll

Mac OS X (works in 10.14!)
Windows stand alone: https://www.stereotool.com/download/ste ... 11-004.zip
Windows stand alone: https://www.stereotool.com/download/ste ... 04.vst.zip


For those who are using stream input/output via libVLC: libVLC 3 is now also supported. The API was changed, but there was a common API that works in both VLC 2 and 3, and we're using that now. We have not yet thoroughly tested this, and we're not too sure if errors in the stream (for the output) are detected.

There used to be some stability issues with the old libVLC 2 integration with streams using specific codecs, we don't know if they are solved now. The new API works very differently from the old one so it's possible.


CHANGES:
  • libVLC 3 supported. So now both VLC2 and VLC3 should work. (Not yet thoroughly tested).
  • libVLC restarts all the time if watchdog is enabled - turning it off fixes it. -> if (r > 0) replaced by if (r == 0), should solve it.
  • Some streaming settings were only visible in Expert mode - should be always.
  • Linux .so build without X11 dependencies.
  • Linux bug fix: 32 bit R128 code crashes
  • Trip waveform jumps (see video)
  • 32 bit VST doesn't appear to work under XP (8.54 was ok).
  • RDS: TMC data PSN/DSN filtering fixed.
  • RDS: EON channel selection added.
  • Fix crackle in Wasapi on some Realtek pc's in MicroMPX - Was a driver issue, block size can be restored to 4096.

    REMAINING TODO:
  • Can we build WatchCat with /MT?
  • Linux .so build error.
  • Restore 4096 for MicroMPX sound card I/O.
  • Increase resampling margins MicroMPX.
  • Check clipper sound (probably ok)
  • Linux 32 bit .so file still crashes
  • Fix warnings
  • WatchCat Windows 4K fonts, menu etc
  • BriOm
  • Proppfrexx integration error since 9.00: Also on Windows 10 (until now only reported on Windows Server), test...

    LATER:
  • RDS AF method B, longer lists
  • RDS AF method B via UECP Probably done but can't test it now.
  • White screen in generic plugin - was caused by wrong #ifdef
  • I/O and BIMP missing in web interface.
  • Volume display FM output seems wrong when streaming output is enabled with separate processing. Almost certainly only GUI issue.
  • Noise gate windows audible
  • Auto-select 192 kHz FM output sound card as default
  • Linux MicroMPX version
  • Dutch Moose schelle vrouwenstemmen
  • Linux-version MicroMPX integration in ST.
  • Pi 64 bit builds on the site
  • Support for more than 32 ASIO channels
  • Automate generating MicroMPX licenses
  • Automate generating The BIMP licenses
  • Backup audio doesn't go to LQLL
  • Finish Kantar tests and integration
  • Brian, NAB
  • VST for DJB
  • MicroMPX: highs idea BUSY -> Find beta testers TEST STOKKEMASK EFFECT TOMORROW
  • Test sound card
  • Linux multiple instances
  • Matrix stereo widener BUSY, problem with suddenly loud stereo (goes down in level, makes everything pump - badly). Try running L+R with a slower attack speed, if that doesn't sound good, remove it.
  • Fake stereo idea
  • Optimize Stokkemask post filter
  • Cntrct IN
  • Show warning when using MME with wrong sample rate
  • Add a popup for buffer overrun/underrun (also for suspicion)
  • Bug report: Linux version uses 100% CPU on one thread, even in bypass mode (must be sound card thread?) -> Not here. Not sure what's going on.....
  • Test ProppFrexx Windows 2012 server issue-
  • Declipper: Put startup in system tray back in Declipper (at least in the Winamp plugin version).
  • RDS: EON: Support for other type of AF frequencies?
  • RDS: RT end at \n
  • uMPX encoder/plugin: Sound card speed message
  • Add MagicRDS AF method B support
  • Noise in declipper issue


Top
   
PostPosted: Sun Oct 21, 2018 6:31 am 

Joined: Tue Mar 10, 2015 9:03 pm
Posts: 119
Location: Utah, USA
Noise in Declipper from a post on FB months ago?

_________________
America's Country
Hot Country Hits!


Top
   
PostPosted: Sun Oct 21, 2018 9:49 am 

Joined: Sun Oct 21, 2018 9:44 am
Posts: 1
It is recommended to add a dual stream receiver :D


Top
   
PostPosted: Mon Oct 22, 2018 8:49 am 

Joined: Thu Oct 05, 2017 10:12 am
Posts: 3
Any news about fixing the GUI-problem for macOS 10.14 (Mojave)?


Top
   
PostPosted: Mon Oct 22, 2018 10:36 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9741
Quote:
Any news about fixing the GUI-problem for macOS 10.14 (Mojave)?
Ah! I forgot to include that one. Yes, it's fixed. Will post it here in a moment.

Edit: Added on top!


Top
   
PostPosted: Wed Oct 24, 2018 10:50 am 

Joined: Thu Oct 05, 2017 10:12 am
Posts: 3
OS: macOS 10.14 (Mojave)
When i'm trying to load some presets, for example "Bojcha - Dynarider", the whole application crashes.
No error messages, no nothing.

The same thing happens when I try to set the Title bar info in User interface Settings.


Top
   
PostPosted: Wed Oct 24, 2018 8:18 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9741
Quote:
OS: macOS 10.14 (Mojave)
When i'm trying to load some presets, for example "Bojcha - Dynarider", the whole application crashes.
No error messages, no nothing.

The same thing happens when I try to set the Title bar info in User interface Settings.
Ok, something is odd. Mathijs confirmed that the version on the forum crashes - but the version that I built and he tested before was fine. We'll look into this tomorrow. I hope to have a fix in the afternoon.


Top
   
PostPosted: Thu Oct 25, 2018 2:25 pm 
User avatar

Joined: Sun Mar 27, 2016 10:15 pm
Posts: 84
Quote:
OS: macOS 10.14 (Mojave)
When i'm trying to load some presets, for example "Bojcha - Dynarider", the whole application crashes.
No error messages, no nothing.

The same thing happens when I try to set the Title bar info in User interface Settings.
That's sounds familiar, in raspberry tests we performed earlier I had the same, the explorer function reponded odd anyway while loading a preset I remember, currently we cannot test this version since we use 3B+ boards and the board asks what program it should use to run the software when trying to start the jack version (this was once again tested here on 9.02) also 3b (china) and 3b+ (sos sollutions) are the only ones at hand and in stock for 30-35 dollar / euro currently so the raspberry version is a little outdated also.

_________________
https://dreamstream.mobi

Currently live processing ST 9.02 , testing upgrade to auto equalizer offline using slightly modified 3 FM settings Bojcha


Top
   
PostPosted: Thu Oct 25, 2018 2:33 pm 
User avatar

Joined: Tue Sep 15, 2015 12:22 pm
Posts: 229
Quote:
That's sounds familiar, in raspberry tests we performed earlier I had the same, the explorer function reponded odd anyway while loading a preset
It was a mac-specific issue, so at least it's not related.
Quote:
I remember, currently we cannot test this version since we use 3B+ boards and the board asks what program it should use to run the software when trying to start the jack version
It has to be started from the command line and has to be given execution rights.

_________________
Software Engineer @ Thimeo Audio Technology B.V.


Top
   
PostPosted: Thu Oct 25, 2018 6:10 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9741
Quote:
also 3b (china) and 3b+ (sos sollutions) are the only ones at hand and in stock for 30-35 dollar / euro currently so the raspberry version is a little outdated also.
They aren't outdated, they run on all Pi 2/3's (so also 3B+). We can target the CPU in those specifically but we tried that and it makes very little difference in performance (1%, maybe).

Note: If you have a chance, get a 64 bit OS on those Pi's, plus the 64 bit binaries (we'll post those for version 9.10). That does make quite a large difference (10% or so).


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 14 posts ]  Go to page 1 2 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited