All times are UTC+02:00




Post new topic  This topic is locked, you cannot edit posts or make further replies.  [ 289 posts ]  Go to page Previous 124 25 26 27 28 29 Next
Author Message
 Post subject: Re: Stereo Tool 9.00
PostPosted: Wed Jul 18, 2018 10:32 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Quote:
There's still something off with the Dutch Moose preset. The bass we talked about earlier is steady now but overall there are loud volume spikes. I'm talking about perhaps coming from a very quiet section to a very loud one, it's too slow to bring the volume back down or the other way around.

One good example is the very beginning of the song Amorphis - Message in the Amber. The song starts heavy and loud and already one second into the song the preset has a very noticeable and abrupt volume change. It goes from loud to soft, too slowly I think, so it's a very annoying effect.

I can upload a sample if you want, it would be processed with WatchCat from a .flac file.
Hi, is this with the latest one (built in in the latest beta)? I did make some more changes in it. I'll check tomorrow.


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Wed Jul 18, 2018 10:35 pm 

Joined: Tue Jun 26, 2012 10:18 am
Posts: 36
Quote:
Quote:
There's still something off with the Dutch Moose preset. The bass we talked about earlier is steady now but overall there are loud volume spikes. I'm talking about perhaps coming from a very quiet section to a very loud one, it's too slow to bring the volume back down or the other way around.

One good example is the very beginning of the song Amorphis - Message in the Amber. The song starts heavy and loud and already one second into the song the preset has a very noticeable and abrupt volume change. It goes from loud to soft, too slowly I think, so it's a very annoying effect.

I can upload a sample if you want, it would be processed with WatchCat from a .flac file.
Hi, is this with the latest one (built in in the latest beta)? I did make some more changes in it. I'll check tomorrow.
It was actually from beta 011. I'll try 013 now. Check my previous post by the way, I made some samples already.

Still the same in beta 013 preset. I loaded (Stereo Tool) in MediaMonkey, then exported it as a settings file and used with WatchCat. The same volume spike still very noticeable and can be seen in Audacity.


Last edited by jez on Wed Jul 18, 2018 10:46 pm, edited 1 time in total.

Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Wed Jul 18, 2018 10:45 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Ah. The deep bass is constant, the spike is mainly in the highs apparently - but also in mid-bass. I don't have a good speaker here now (I'm not in my office) so I'm purely speaking based on looking at the waveform in Audition. Will listen tomorrow morning.

-> Ok, re-read your comment and it wasn't about the bass at all :( . Ok will check this one - it should go down way faster than it does here.

-> It's AGC Sudden Jump Protection. If I set the detection values to 5 and 8 instead of 10 and 16, the effect is mostly gone. I still have to test for side-effects (so far it looks good).

Edit: There are some side effects, but they actually appear to be good instead of bad. The huge spikes are removed before entering the multibands, so they move down less deep. And the initial spikes are caught by the AGC. So, I'll update this in the preset.
The effect isn't completely gone, but that's not really possible without killing all dynamics in dynamic tracks.


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Thu Jul 19, 2018 4:16 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Quote:
Hi, Hans! Will you add in 9's version?

- RDS RT end with hex code 0D (Carriage Return) instead of padding with spaces, then stop sending - faster and no unnecessary scrolling.
Hi,

That one is still on my todo list.


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Thu Jul 19, 2018 6:11 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Quote:
In case you missed it, I posted a thread in the Bug Report forum with an audio track that causes the Delossifier to add "broken speaker" sounding kinds of distortion to it. :|
I've added a new slider that controls how much correction may be done. If it tries to add too much stuff, I assume that it's bad and turn it off. For the track that you sent me before, this fully fixes the issue. I'm going to run a new build now. The new setting is called "Maximum gap size", default value is 30% (20% seems just sufficient to not affect 96 kbit/s MP3's, at 35% I'm starting to hear things in your test track again).

I will add another thing that should completely stop it to try to recover anything in your test track - it's incorrectly detecting it as an MP3, and I will fix that. But both fixes are useful; if you would encode this track as an MP3 then it would still add these weird chirping sounds without today's fix.


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Fri Jul 20, 2018 2:04 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Stereo Tool 9.02 BETA015

1. Not only Stereo Tool, but also the MicroMPX encoder that's now built into this Stereo Tool build is a beta version.

One person had hiccups with MicroMPX, which was probably caused by the block size with which we were communicating with the sound card. I've quadrupled it, which appeared to fix the problem, but caused crashes. This build has the original value x2. I will look into the crash later.

EDIT: Just fixed a potential issue of that crash (the issue was introduced 2 days ago so it might be it), uploaded MicroMPX version 016.



Windows 32 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 02-015.exe
Winamp DSP: https://www.stereotool.com/download/dsp ... 02-015.exe
VST: http://www.stereotool.com/download/vst_ ... 02-015.dll
MicroMPX web based decoder: https://www.stereotool.com/download/Mic ... 02-016.exe UPDATED - 016
MicroMPX web based encoder: https://www.stereotool.com/download/Mic ... 02-016.exe UPDATED - 016
MicroMPX command line enc/dec: https://www.stereotool.com/download/Mic ... 02-016.exe UPDATED - 016
libsndfile-1.dll (needed for MicroMPX decoder and command line version, place in same directory): MicroMPX command line enc/dec: https://www.stereotool.com/download/libsndfile-1.dll

Windows 64 bit:
Windows stand alone: https://www.stereotool.com/download/ste ... 02-015.exe
VST: https://www.stereotool.com/download/vst ... 02-015.dll

ARM (Raspberry Pi 2/3 etc) 32 bit STILL BUILDING
MicroMPX web based decoder: -.stereotool.com/download/MicroMPX_Decoder_ARM32_BETA902-016
MicroMPX web based encoder: -.stereotool.com/download/MicroMPX_Encoder_ARM32_BETA902-016
MicroMPX command line enc/dec: -.stereotool.com/download/MicroMPX_ARM32_BETA902-016


CHANGES:
  • Delossifier issue: viewtopic.php?f=15&t=25151&p=56911#p56911 Problem 2: Huge area is reconstructed. We should have a maximum gap size. Detect more = turn OFF (safety failover) -> Added "Maximum gap size" slider, default is 30% (20% seems enough for even 96 kbit MP3's, above 35% I start hearing bad stuff in the test track from AllNight - default value is 30% to be on the safe side (not too much effect compared to before)).
  • Fixed potential crash after NAN
  • Fixed: More meters than I allocated memory for - fixed and extra assert added. Could cause GUI crashes
  • Add "(Not found)" to missing sound card in menu.
  • Add clear error message if sound card that doesn't exist in the system is selected.
  • MicroMPX command line: Exception logger was not initialized (command line version)
  • MicroMPX: Fixed 64 bit Pi build
  • Update presets Wes
  • Check Dutch Moose preset response to loud burst -> Done and improved
  • MicroMPX: %zu causes compiler warning in 64 bit build -> Was incorrectly changed from %llu, put %llu back. Only 2 locations. (016)

    OLD CHANGES:
  • MicroMPX: c0000409 error on startup fixed (logging issue)
  • MicroMPX decoder: Redesigned and optimized time synchronization code
  • MicroMPX decoder: Could crash on close
  • MicroMPX encoder: Error when continuously changing IP address in GUI
  • Multiband clipper levels were affected by Band Mix
  • MicroMPX: Moved to more logical location in Stereo Tool menu
  • Check sound of Analog Pleasure Big FM in 7.84 vs 8.23 vs 8.40 vs 9.02. -> Reported that 7.84 sounds much better than 9.02, but 7.84 and 9.02 are virtually the same here..
  • MicroMPX sounded very bad in 64 bit Stereo Tool build - wrong compiler setting for 64 bit, fixed.
  • MicroMPX: Can't handle "Ignore high frequencies" values other than 19200.
  • MicroMPX: Stereo Tool built-in encoder does not get activated (and "Force generate composite doesn't work either) when the FM output is running in ASIO mode at 44/48 kHz. -> Changed, now the FM output will play silence and show an error message in this situation.
  • MicroMPX: Stereo Tool built-in encoder didn't output valid data for certain "Ignore high frequencies" settings. Limited the number of accepted frequencies to 19200 Hz and the normal maximum.
  • Check MB1 clip display -> Was indeed missing, fixed.
  • Update preset Dutch Moose
  • Add sweep tones (30-60000 and 10-80000 Hz)
  • Add MagicRDS hex number support
  • ClockShift redesign: Extremely heavy now.
  • c0000409 error Added logging
  • Added MicroMPX encoder to Stereo Tool!
  • Add ThimeoKoekError to Stereo Tool
  • uMPX decoder: Not stable with password protection, and asserts on bad data (should just print a warning)
  • uMPX: decoder: Check password activation on startup
  • uMPX decoder: License was saved in current directory, which fails in Program Files.
  • uMPX decoder: Ignore ticks for too late packets
  • Redesign ClockShift - seems better than before (needed to measure sound card sample rate offset - to keep MicroMPX decoder in sync)
  • Multiband 2 clipper default values were taken from earlier version and set to -infinity dB, leading to silence (BETA004).
  • GUI priority is too low now (BETA003/004) - removed lowering it for plugin version.
  • GUI: 4K weird flashing since last Windows update
  • RDS: Support for ODA. probably ok
  • RDS: Support for EON Partially working, need to add burst mode, linkage, freqs, turning on/off via command
  • RDS: EON: Support for multiple AF frequencies
  • MicroMPX crashes on closing -> Join thread was missing
  • uMPX: Add entering & applying hash
  • uMPX encoder: Add new settings to separate encoder
  • uMPX decoder: Add password + hash
  • SST build fails, incorrectly including something from MicroMPX somehow?
  • Made MB clipper completely separate from limiter, so you can now use both at the same time
  • Input level meter can flash black on Mac. Cause unknown, doesn't really reproduce in a clear way. -> Value was set to 0 after displaying and could be displayed again before a new value was set.
  • Output scope runs too slow in certain situations
  • Output scope can lag behind (GuntherM) -> Probably fixed by previous fix, waiting for feedback
  • Check uMPX disabled when FM disabled -> Yes, but GUI wasn't.
  • Mac VST plugin didn't work.
  • Add MB clipper to MB1 as well. Decide if limiter AND clipper needed simultaneously (probably not?)
  • Update build script - remainder - Woohoo, full build now takes 12 hours (was 30)
  • Add MB clippers
  • Lower GUI thread priority for plugin versions.
  • Make Windows event thread priority equal to GUI thread priority. (Affinity was already ok)
  • Set minimum size on VST version (1500x843)
  • Update build script for much faster build - partially done

    PLANNED:
  • Delossifier issue: viewtopic.php?f=15&t=25151&p=56911#p56911 Problem 1: Background isn't dark enough nearby, so no MP3 should be detected.
  • MicroMPX: highs idea: Try AVG instead of SQRT
  • MicroMPX: highs idea BUSY -> Find beta testers
  • Try I/Q Clipper mode BUSY, first part works
  • Test preset that causes buffer to run empty - why? --> Settings issue, maybe add a popup for this situation (buffer is slowly filling up or running empty)...
  • Bug report: Linux version uses 100% CPU on one thread, even in bypass mode (must be sound card thread?) -> Not here. Not sure what's going on.....
  • Test 64 bit sound card exception handling in ProppFrexx - that wasn't the problem... apparently
    -
  • RDS: EON: Support for other type of AF frequencies?
  • RDS: Support for AF method B
  • RDS: RT end at \n
  • Brian, NAB
  • MOBO
  • uMPX encoder/plugin: Sound card speed message
  • uMPX decoder: Add multicast subscribe
  • Add MagicRDS AF method B support


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Fri Jul 20, 2018 4:15 am 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3283
Why not block size adjustable?

For example My Juli@ at 48kHz on MME likes 1920 size. With KS it's perfect at 512 size... etc. Depending on sample rate and soundcards.. it asks different ideal block size.

_________________
control point


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Fri Jul 20, 2018 8:44 am 

Joined: Tue Jun 26, 2012 10:18 am
Posts: 36
Quote:
Ah. The deep bass is constant, the spike is mainly in the highs apparently - but also in mid-bass. I don't have a good speaker here now (I'm not in my office) so I'm purely speaking based on looking at the waveform in Audition. Will listen tomorrow morning.

-> Ok, re-read your comment and it wasn't about the bass at all :( . Ok will check this one - it should go down way faster than it does here.

-> It's AGC Sudden Jump Protection. If I set the detection values to 5 and 8 instead of 10 and 16, the effect is mostly gone. I still have to test for side-effects (so far it looks good).

Edit: There are some side effects, but they actually appear to be good instead of bad. The huge spikes are removed before entering the multibands, so they move down less deep. And the initial spikes are caught by the AGC. So, I'll update this in the preset.
The effect isn't completely gone, but that's not really possible without killing all dynamics in dynamic tracks.
Nice, thanks! Seems like it's fixed now in 015. I'll go through some albums to test out more and hopefully can start building my cloud library with WatchCat processed music files!


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Fri Jul 20, 2018 9:43 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9411
Quote:
Why not block size adjustable?

For example My Juli@ at 48kHz on MME likes 1920 size. With KS it's perfect at 512 size... etc. Depending on sample rate and soundcards.. it asks different ideal block size.
It's not so much the card that's asking for a different block size, in this specific case where it caused issues it was a Core2Duo with - as the name says - only 2 cores, where apparently the decoding was interfering with the I/O.
If we have to we can do it - but if it's not needed, I'd rather keep it simple....


Top
   
 
 Post subject: Re: Stereo Tool 9.00
PostPosted: Fri Jul 20, 2018 12:51 pm 

Joined: Sat Nov 10, 2012 2:16 am
Posts: 41
Location: Australia
Quote:
Stereo Tool 9.02 BETA015
Windows 64 Bit Standalone B015 + microMPX B016
Attachment:
ST902-B015_microMPX-B016.JPG
ST902-B015_microMPX-B016.JPG [ 66.33 KiB | Viewed 149 times ]
Would be possible (or worthwhile) to add a command line to microMPX to allow for a pilot and/or RDS guard (filter) to protect either of them from transients/audio spikes?

The top is ST output into a low power test TX, the bottom is me decoding the same signal via MPXTool.
At the level where I can no longer decode RDS via RDSSpy from the PIRA using the microMPX output (same card type), can switch across to the MPX output into the same TX and reduce power by another 15-20% before I loose RDS from the MPX derived from ST directly.
I realise that some of this stems from the the nature of the codec (per previous post) but thought I'd throw the idea up for review.

Cosmetic display bug: The FM Lowpass frequency value is being shown on the main screen for both the FM and Bandpass Lowpass frequency values.

Rossco


Top
   
 
Display posts from previous:  Sort by  
Post new topic  This topic is locked, you cannot edit posts or make further replies.  [ 289 posts ]  Go to page Previous 124 25 26 27 28 29 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited