All times are UTC+02:00




Post new topic  Reply to topic  [ 759 posts ]  Go to page Previous 149 50 51 52 5376 Next
Author Message
PostPosted: Fri Apr 06, 2018 8:01 pm 

Joined: Mon Aug 25, 2014 3:22 pm
Posts: 243
Quote:
"I get an exception in beta 060 when i load the new presets from Wes and Bojcha."

Where are these new presets from Wes and and Bojcha?
I'm seeing them in the FM 75us section of the preloaded presets. They probably exist other places, too.


Top
   
PostPosted: Fri Apr 06, 2018 8:47 pm 
User avatar

Joined: Tue Mar 17, 2009 2:56 pm
Posts: 3312
Attachment:
DynaRider_NEW_v0.00.50-HD_ST_9.00b060.sts [119.03 KiB]
Downloaded 132 times
Attachment:
DynaRider_NEW_v0.00.42-FM_50us_ST_8.55b059.sts [119.06 KiB]
Downloaded 84 times
FM Version need to catch HD version.

_________________
control point


Top
   
PostPosted: Fri Apr 06, 2018 9:13 pm 

Joined: Sun May 21, 2017 12:10 am
Posts: 14
Quote:
DynaRider_NEW_v0.00.50-HD_ST_9.00b060.sts
DynaRider_NEW_v0.00.42-FM_50us_ST_8.55b059.sts

FM Version need to catch HD version.
Thanks!


Top
   
PostPosted: Sat Apr 07, 2018 2:24 am 

Joined: Fri Mar 29, 2013 3:04 pm
Posts: 102
Hans, you might want to check my previous post regarding the "Legacy Mode" bug for the VST version of Stereo Tool. It affects both 32 and 64 bit.

That is, "Legacy Mode" is enabled by default unless the user switches to an operating mode higher than "Basic" and changes it, or selects "Reset" -> "All Settings (Factory Reset)" every time Stereo Tool is run, unless the user is using a DAW or host that retains previous settings.

The modules this affects include AutoEQ, Low Level Boost, and AGC.

There are ALSO bugs with Multiband and Multiband 2 as well! They default to "Legacy Mode" for the "Limiters" section, regardless if a factory reset is performed. That may be intentional there, but...

ALSO, if the user performs a factory reset, they lose the ability to select "Digital" or "Analog" for the compressor type for Multiband and Singleband; they will be stuck in Analog mode. (Multiband 2 is always Analog.)

In fact, when loading Stereo Tool VST for the first time (i.e., no .ini file), the user is also unable to select "Digital" or "Analog" for the compressor type for Multiband and Singleband. They will have to do "All Settings (Factory Reset)", then re-load Stereo Tool VST. If using a DAW which retains settings, they will have to clear this before reloading the Stereo Tool VST. And of course, re-loading Stereo Tool without doing "All Settings (Factory Reset)" will mean that "Legacy Mode" is enabled by default for AutoEQ, Low Level Boost, and AGC.

What a mess! :o Hope you can fix... and hope there aren't other things affected by this. :?

I did check and this is all still happening in the latest beta at the time of this post (v9.0 Beta 60).


Top
   
PostPosted: Sat Apr 07, 2018 8:11 am 

Joined: Fri Mar 29, 2013 3:04 pm
Posts: 102
OK, I just checked EVERY setting. To make things clear (for reproducing):

- Start clean (i.e., no .ini file in C:\Users\[USERID]\ directory)
- Load Stereo Tool VST into DAW which does NOT REMEMBER SETTINGS (i.e., Wavosaur)
- Enter License
- Select "Reset" -> "All Settings (Factory Reset)"
- Exit and restart DAW. Reload Stereo Tool VST. Set operating mode to "Extreme Tweaker". Set your choice of skin or leave default.

Now, there are differences in default settings, depending on if you AGAIN select "Reset" -> "All Settings (Factory Reset)":
 
  • Phase rotation: If "Reset" -> "All Settings (Factory Reset)" is performed, "At start of processing" button disappears. Otherwise it will be visible.
     
  • Auto EQ: If "Reset" -> "All Settings (Factory Reset)" is performed, "Legacy mode" will not be selected. Otherwise it will be selected.
     
  • Low Level Boost: If "Reset" -> "All Settings (Factory Reset)" is performed, "Legacy mode" will not be selected. Otherwise it will be selected.
     
  • AGC: If "Reset" -> "All Settings (Factory Reset)" is performed, "AGC type" drop down will NOT be available, and will be permanently set to the "Current AGC" setting. "Legacy mode" will not be selected. Otherwise, "AGC type" drop down will be available, preset to "Legacy AGC," and the "Legacy mode" setting will be enabled. Also, until the user drags a window over the drop box, or toggles the skin, there are drawing errors:

    Image
     
  • Basstadizer: If "Reset" -> "All Settings (Factory Reset)" is performed, "Use Legacy mode (Bass Boost)" will not be selected, and Basstadizer defaults will be selected (although in the GUI, the column heading is spelled "Bassta r dizer"). Otherwise, "Use Legacy mode (Bass Boost)" will be selected, with Bass Boost defaults selected.
     
  • Multiband: If "Reset" -> "All Settings (Factory Reset)" is performed, "Compressor type" drop down will NOT be available, and will be permanently set to the "Analog" setting. Otherwise, "Compressor type" drop down will be available, preset to the "Digital" setting and defaults.

    Note: On the first Multiband's "Limiters" subsection (for analog mode), "Limit before compress" and "Legacy" mode all have check mark toggles enabled by default whether "All Settings (Factory Reset)" is performed or not, but they are grey, which seems to suggest they are not used, as are the "Limit speed" sliders. This isn't the case on the "Limiters" section for "Multiband 2".
     
  • Singleband: If "Reset" -> "All Settings (Factory Reset)" is performed, "Compressor type" drop down will NOT be available, and will be permanently set to the "Analog" setting. Otherwise, "Compressor type" drop down will be available, preset to the "Digital" setting and defaults.
 
Hope this info is helpful!


Top
   
PostPosted: Sat Apr 07, 2018 8:11 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9471
I think I found the cause of the crash when loading presets, while sitting in the Minneapolis airport. Internet connection was pretty bad and my pc decided to perform a Windows update :( so I don't know yet if I fixed it.


Top
   
PostPosted: Sat Apr 07, 2018 8:55 am 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9471
Quote:
OK, I just checked EVERY setting. To make things clear (for reproducing):

- Start clean (i.e., no .ini file in C:\Users\[USERID]\ directory)
- Load Stereo Tool VST into DAW which does NOT REMEMBER SETTINGS (i.e., Wavosaur)
- Enter License
- Select "Reset" -> "All Settings (Factory Reset)"
- Exit and restart DAW. Reload Stereo Tool VST. Set operating mode to "Extreme Tweaker". Set your choice of skin or leave default.

Now, there are differences in default settings, depending on if you AGAIN select "Reset" -> "All Settings (Factory Reset)":
 
  • Phase rotation: If "Reset" -> "All Settings (Factory Reset)" is performed, "At start of processing" button disappears. Otherwise it will be visible.
     
  • Auto EQ: If "Reset" -> "All Settings (Factory Reset)" is performed, "Legacy mode" will not be selected. Otherwise it will be selected.
     
  • Low Level Boost: If "Reset" -> "All Settings (Factory Reset)" is performed, "Legacy mode" will not be selected. Otherwise it will be selected.
     
  • AGC: If "Reset" -> "All Settings (Factory Reset)" is performed, "AGC type" drop down will NOT be available, and will be permanently set to the "Current AGC" setting. "Legacy mode" will not be selected. Otherwise, "AGC type" drop down will be available, preset to "Legacy AGC," and the "Legacy mode" setting will be enabled. Also, until the user drags a window over the drop box, or toggles the skin, there are drawing errors:

    Image
     
  • Basstadizer: If "Reset" -> "All Settings (Factory Reset)" is performed, "Use Legacy mode (Bass Boost)" will not be selected, and Basstadizer defaults will be selected (although in the GUI, the column heading is spelled "Bassta r dizer"). Otherwise, "Use Legacy mode (Bass Boost)" will be selected, with Bass Boost defaults selected.
     
  • Multiband: If "Reset" -> "All Settings (Factory Reset)" is performed, "Compressor type" drop down will NOT be available, and will be permanently set to the "Analog" setting. Otherwise, "Compressor type" drop down will be available, preset to the "Digital" setting and defaults.

    Note: On the first Multiband's "Limiters" subsection (for analog mode), "Limit before compress" and "Legacy" mode all have check mark toggles enabled by default whether "All Settings (Factory Reset)" is performed or not, but they are grey, which seems to suggest they are not used, as are the "Limit speed" sliders. This isn't the case on the "Limiters" section for "Multiband 2".
     
  • Singleband: If "Reset" -> "All Settings (Factory Reset)" is performed, "Compressor type" drop down will NOT be available, and will be permanently set to the "Analog" setting. Otherwise, "Compressor type" drop down will be available, preset to the "Digital" setting and defaults.
 
Hope this info is helpful!
This is *partially* the intended behavior.

For many of these settings, the new (better) option replaces the old one (that's still available for compatibility reasons). Once you select the new setting, the selection itself disappears. If you want to see them anyway, enable "Show deprecated settings" (under Configration).

What's wrong is this: The default preset after loading is very old, and because of that, uses many of the old (legacy/digital mode etc) settings. I guess I need to relace it. That would remove this difference.


Top
   
PostPosted: Sat Apr 07, 2018 5:01 pm 
Site Admin
User avatar

Joined: Mon Mar 17, 2008 1:40 am
Posts: 9471
Stereo Tool 9.00 BETA061

NAN LOGGING REMOVED!

Windows 32 bit:
Windows stand alone: http://www.stereotool.com/download/ster ... 00-061.exe
Winamp DSP: http://www.stereotool.com/download/dsp_ ... 00-061.exe
VST: http://www.stereotool.com/download/vst_ ... 00-061.dll

Windows 64 bit:
Windows stand alone: http://www.stereotool.com/download/ster ... 00-061.exe
VST: http://www.stereotool.com/download/vst_ ... 00-061.dll STILL BUILDING


CHANGES:
- Fixed preset load error (060)


OLDER CHANGES:
- Pi MicroMPX builds (and 32 bit Jack build). MicroMPX: #include "pa_linux_alsa.h", #include "licenseclient.h" PROBABLY OK, testing.
- Add presets ST (Wes + SJP, Bojcha)
- Add presets SST (Wes + SJP, Bojcha)
- Fix skin SST - most important part done
- NAN logging disabled again
- SST and Pi builds working again
- NAN in equalizer fixed
- UECP: Support added for combined messages in 1 packet
- Hard Limit apparently sounds bad again & blinks in red :( Waiting for feedback
- 2 = signs in translation rules
- 056 crash on older CPU's/WinXP fixed
- Quality slider extended to 150% - WARNING, HUGE CPU LOAD - but useful for NAN testing
- NAN and other weird behavior in multi-thread mode: Found and fixed potential issues in Bass EQ, Bass In Your Face and Absolute Highs. Added a whole bunch of asserts that so far aren't complaining.
- Check equalizer NAN (does recover, so not a complete disaster - but it shouldn't happen). -> Extra logging added, waiting if it happens again.
- Add GUI gamma slider [THURSDAY]
- Fixed potential Bass EQ NAN error when switching between presets with multiple threads active
- Added extra NAN logging to equalizer because a NAN was reported that was caused there, but I have no idea why. So if it happens again, more info will be logged...
- Near05 VST crash -> Intel library could be called with a NULL pointer argument when initializing with Phase Delay enabled - hopefully that was it. Waiting for feedback
- Make Bass Boost output also show Basstardizer
- near05 VST crash -> Added try/catch
- Changed processing core (no effect should be noticeable at this point)
- Combine Basstardizer with Bass Boost
- Check \_/'s window size changes (sounds like the border size is subtracted or something like that)
- Remove small check boxes that were added for testing.
- Fixed bug that caused certain AGC settings to behave completey wrong (silence most of the time).
- Fine-tune Auto EQ behavior at the start of a song (might be ok now, but needs more testing)
- Fixed a possible GUI crash at certain specific window size in 4K mode
- Hard limit overshoots (red blinking)
- Is pre AGC affecting audio levels? (With BS412) -> Not specifically for BS412, but it slightly reduces the level even if set a lot higher. Probably needs some offset. -> No, just raise threshold.
- Add NAN recovery in Normal Limiter
- New skin
- Improved Auto EQ/Bass EQ max boost calculation
- Bass EQ first band might not go down fast enough
- Check scaling issue in non-4K mode
- Check Auto EQ behavior at the start of a song => Problem was caused by Abrupt Change Protection compensation that I added recently...
- NAN seen when switching to new compressor mode which also doesn't get recovered - silence afterwards. (Peak mode recovers it though). => Not seen since, must have been something in the earliest version of it.
- Auto EQ move where_i_am back to close to min/max settings to avoid insane response times without SJP
- 4K mode line spacing bigger for presets
- Make default window size bigger for 4K
- Fixed threading issue that was introduced in Sudden Jump Protection a few beta's ago.
- Minimum window size in 4K mode
- Added Basstardizer lowpass filter for output
- Make VST plugin error catching work again.
- Optimized new compressor modes, created separate code paths, put values in a lookup table. Performance vs. legacy mode: Auto EQ 5% faster, AGC same, Symmetric RMS vs RMS 7% faster (if not using Exponential Release, Spectal Balance Compensation etc), Symmetric Peak vs Peak 54% heavier (because it's now based on Symmetric RMS mode instead of Averaging mode, and all RMS modes are heavier than Averaging modes). Compared to BETA037 the performance is 13% better for the Symmetric modes.
- Fix Basstardizer crash
- Fix Basstardizer right window shape
- Fixed Digital Multiband 1 mode Flat frequency response bug introduced in 8.54.
- Fixed Symmetric Peak
- Fixed an issue in Symmetric Peak and Symmetric RMS mode with Feedback^2 enabled, for very fast attack times the Shape is higher now to avoid overreacting.
- Fixed Basstardizer: The threshold calculation was completely wrong, it worked fine on constant bass but not on dynamically changing bass.
- Basstardizer: Make Effect strength slider relative to Headroom (which turns into Harshness) - At higher Softness settings Lookahead now controls punch!
- Fixed DLL closing issue (in Audition and other programs; calling a DLL close from program close caused a hangup)
- Added mono bass fiter to reduce multipath
- Added extra protection mechanism to avoid insane release speeds. For MB, MB2, SB Compressor this can be switched on/off for testing - I will remove the checkboxes once tested.
- Relative release threshold was not calculated correctly for FB and FB^2 modes.
- Moved RECOVER_FROM_NAN outside of adjustChannel_internal_linear_attack_release_feedback_peak_peak_gate_limit to fix compiler crash.
- Bass mono fiter to reduce multipath Done, but parameter needs to be controllable separately.
- Added Symmetric Peak mode. Not at all tested yet!!
- Added Stop Threshold values for multiband compressors. They were already there for the singleband compressors, but not yet for multiband!
- Symmetric modes were visible for Digital compressor but not supported by Digital mode!
- Added "Relative release threshold" slider; removed Symmetry slider. For all dynamics processing things (so LLB, AGC, Auto EQ, compressors). Not 100% sure yet if this is a good idea for Auto EQ. See text below (*)
- Max release speed fixed
- Basstardizer: Fixed issue with difference between left and right
- Crash reported by near05 (fixed?)
- Improved external RDS insertion to allow for noisy RDS signals (some encoders (actually apparently from one specific brand) generate a pretty bad signal, which was rejected by Stereo Tool).
- Added sound card lowpass filter compensation to FM output sound card (so now beside tilt for bass there's also something for highs). NOT YET FINISHED, may cause weird behavior. It will work in many cases, but not in all. Does not work when "Ignore high frequencies" is used. Description will follow when finished.
- New compressor mode. Check all weird settings, optimize, new peak mode, remove faster attack/release, add setting for max release, fix max attack/release speed controls. Things to check: "Peak", "Peak mode", "Feedback", "Feedback^2", "Exponential release", "Max attack speed", "Max release speed". New mode is called Symmetric RMS, there's also a Symmetric Averaging but I will probably remove it because it's not useful. MORE INFO BELOW!
New AGC mode MORE INFO BELOW!
New Auto EQ and Bass EQ mode (not switchable in Bass EQ since that's new anyway). MORE INFO BELOW!
- RDS: Add PTYN
- RDS: Add timeout for TA
- Improved multipath protection
- Improved Stereo Image phase limiter
- Revisit new Hard Limit / Final Limiter with Matt & Wes - Settings removed Waiting for final feedback.
- MPEG detection is too insensitive now -> Probably fixed Waiting for feedback
- UECP UDP mode Waiting for feedback
- TA/TP via MagicRDS. Auto-enable TP if TA is used? (no)
- Added THIMEORT in ASCII RDS mode.
- Spectrum displays are broken in 4K mode
- Compressor/limiter on input before AGC to handle extreme sounds? / 2nd AGC with higher threshold for voice tracks Added, may need new mode. Waiting for feedback.
- Add auto save to Linux build Waiting for feedback
- VST delay appears to be wrong - Phase Delay and Threads
- VST version no 4K
- Backup input - fix overshoot display
- Backup input - check stereo
- Fix web server long URL issue Test release mode needed
- Scrolling through presets in 4K mode locks screen (crashes).
- Pilot-only output for 9 , works but needs to be sent back to O9SG
- Self test crashes
- Fix affinity for Linux and Mac - Mac doesn't support it.
- Edwin's bass effect - is that done now? (Maybe an extra HPF?) -> Not needed for now, based on preliminary tests...
- Put Bass EQ under license
- Do we need multiple Basstardizer bands? -> Doesn't seem like it. Not for now.
- Remove Hans mode from Bass EQ? -> Hid it (Extreme Tweaker mode, Matt mode is default, made it a pulldown instead of a boolean to clarify its behavior).
- Octaviafm extra logging? - Waiting. Once we know the cause I'll run a new build. But I'm not going to hold off releasing the current version, since 1. this issue doesn't have any side effects anymore and 2. it very likely isn't new. -> Nothing heard anymore
- Would multiple where_i_am start points improve attack? YES!!!! Think about how to implement it...
- Enabling low latency output caused crashes
- NAN recovery added to Basstardizer
- Top area of GUI made a bit higher, not all menu items fit before
- Bigger font and widgets on 4K screens
- Added Basstardizer
- Remove warnings that were shown for things that weren't even enabled.
- Fixed NAN in 8.54 in several versions in the clipper (reported by 1 person, appears to have been settings-related).
- Matt's bass effect Ready to get feedback, see "BASS EQ" before or between multibands! See note below.
- Fixed Mac multiband compressor gate error after NAN recovery.
- Add Breakaway Pipeline warning
- Add low input level warning
- Add too little AGC action warning
- Add too much noise gate warning
- Add too much BS412 action warning
- Added ASIO latency setting.
- Made streaming with libVLC easier, WARNING though, the audio quality is still the VLC streaming audio quality, there are better encoders out there. This only affects the stand alone versions.

TODO:
- Mono audio on Matt's machine - why?? Wait for .sts files. -> Was a wrong setting, FM Analyser was enabled.
- Fix Matt's GUI crash
- MicroMPX ifdef stuff
- RDS Compressed flag always set regardless of GUI setting (reported - check first) -> Confirmed, initial load is ignored. - Solved, wrongly initialized, ignored first SetCompresson() call.
- SST & 9sg weird effect for asymmetry -> External RDS input turned Asymmetry off!
- lower output L/R peaks when using external RDS - explained by Asymmetry above
- sg doesn't sound right - probably bad hard limiter Wait for Matt to test
- RDS PS= failure on Swed test files
- Analyser pilot tilt
- AGC PEQ doesn't do live updates
- Sound card high frequency correction: Make sure it always works. -> Not in Ignore high frequencies mode!!!!!
- Muziek uploaden
- Bonus
- Bank dl
- RW
- Rivendell plugin build
- DJB plugin build
- NAS
- Start of song AGC etc behavior. Fixed starting point, for AGC, maybe also for Auto EQ/Bass EQ
- Quality > 100% extreme CPU warning and recovery
- Quality > 100% Bypass switching causes buffer filling to move
- Add "Top presets" per category
- Add AM presets
- Add new presets
- Add display red colors for used but not-licensed stuff in License overview page.
- SST: We should probably put a warning in the next version if the CPU load is high.
- HPF after MB2 causes too loud bass into clipper (after very tightly limiting it - Bojcha)

- Kant
- Auto-setup lower latency settings and slow CPU threading.
- AGC better LKFS (Bojcha)
- Classical preset
- Test NanoPi
- Bojcha's basstardizer filter -> Steeper Output LPF seems to fix the problem -> He doesn't agree
- Check MB2 1% something (see FB chat about crackling sound, which was ok in 8.00). Test with Rhodes54 preset -> Ok. But Spideys Web (7.41 vs 8.54) is different, let's test that. -> No idea, postpone for next release. Comparing the code didn't help.
- MB2 band coupling bug: something is wrong, check better-fg-plus.sts -> Seems ok now. Weird.
- Make pilot generation smooth for external feeds for DARC etc.
- Select instance with command line option
- Basstardizer fadeout (Edwin)?
- AM streaming output
- Multi-instance version
- WatchCat: Use "Simple Clipper" for R128 normalization if there's no license for Advanced Clipper.
- WatchCat/Generic plugin: Respond to latency request with different number for step 1 and 2
- AF method B via UECP
- "Stereo Width" in Stereo Image is broken - it causes phase problems if you're using it to go to mono with silence on the other channel. This can be made smarter!
- True Bass puchier - filter out start
- 18 Hz trigger tone
- Declipper check L-R effects
- Reduce extreme stereo
- Raspberry Pi "gedeelde bibliotheek" melding.
- Check out Butt
- Add libVLC instability warning
- Loudness meter (also for streaming)
- Omnia.9 set Stereo signal. Probably fixed? Wait for answer.
- Omnia.9 test/fix logging
- Omnia.9 AutoPilot add flag for generating noise above pilot?
- WatchCat website
- Triple stuff
- Thumb up/down in GUI for presets

- SCA2 use as backup, feed to output without processing, bypassing normal chain. Use to have FM receiver as backup, and then just feed the full signal to the output.
- uMPX 24x2ch interface
- One bass page

- GUI: Hide disabled stuff, far less confusing / much cleaner interface.
- Talk to chip
- 2 jaar
- Fardau
- -24 dB side chain range?


NOTE: Bass EQ
1. This thing should not really be needed because there's already Auto EQ. However Matt Levin insisted that it's useful, especially now that they are playing very old Christmas music, so let's try it out!
2. There are 2 modes: Matt Mode (see checkbox) or Hans mode (unchecked). In Matt mode, the highest band is not adjusted but it is used to determine the levels. So in the last stage, the highest band is in bypass mode, but the other bands respond as if it's working as well. So the bass is adjusted compared to the full spectrum. In Hans mode, the highest band is ignored completely, so if you use 2 bass bands, they are adjusted to match each other, but not the rest of the audio.


New compressor mode info:
About 3 years ago I wanted to redesign the whole compressor based on how water pressure control systems work. The whole idea was to have a compressor that moves fast when it has to, but stands still when it can. And that it would behave 'naturally' - it's something that you could actually build with real components (if you treat water pressure as audio levels).

This appeared to work pretty well. If you play a dynamic track, the compressor acted fast, and if you play an already compressed track it does nearly nothing. This is great - because it doesn't add 'restlessness' to already compressed audio, which would lead to listener fatigue.

Short summary of the rest of this text: It never worked as I envisioned! (And I never even realized that). But now it does!!

Some people have complained about the attack sometimes working too fast - which was mainly noticeable in loud 'S' sounds. The fast attack with much slower release could cause a 'gap' in the audio after the S. But I figured that that was a more or less logical consequence of the the whole act-fast-when-you-have-to idea.

Now fast-forward a bit. Last year, 2 people (Wes Keene and Matt Levin) were working on a preset together with very high compressor ratios and they noticed that in one particular track, a vocal which was originally louder than the surrounding sound actually came out softer. Well, that's not good. It sounds really annoying and broken. After looking into it I found out that my design was actually not - as I had thought - controlling the level based on RMS levels, but based on average sample levels. In most cases that's closer to RMS than peak, but it's not perfect, and as it turned out, in some cases flat out wrong.

So, I added a new mode that actually controls things based on RMS levels. And - different than many traditional compressors - it would control based on RMS levels regardless of whether it's long time or short time levels that you're looking at. Typically, a compressor would use some window over which it calculates the RMS level, and then control the audio based on that. That works great for most content, but if you play a track that for example has a very loud kick every second or so, the RMS window won't help a bit and your long-term level will probably be too low.

So I created a new RMS mode, renamed the old one to Average mode, and thought I was done. But, the problem with loud "S" sounds has gotten way worse! And it was even worse than that: Release was slower than before. So to fix that, I added some "patches": "Big release speedup" and "Big attack slowdown".

This new mode doesn't need that anymore. It's completely symmetrical, and it's still RMS-based, both on short and long time intervals! It still moves slowly when it can and fast when it has to - but not insanely fast if the attack is really big. And release isn't very slow anymore.

Since attack and release speeds are now virtually identical for RMS and Average mode, and you probably prefer RMS levels over Average levels, the new "Symmetric Average" mode is basically useless. I've put it in for now for testing, but I'll remove it afterwards.

The AGC and Auto EQ were suffering from similar issues, and I've fixed those too. There you can just disable "Legacy mode" - if I'm not wrong, the new mode should be better for any purpose than the old one.


Top
   
PostPosted: Sat Apr 07, 2018 7:26 pm 
User avatar

Joined: Sun Mar 27, 2016 10:15 pm
Posts: 80
Quote:
Stereo Tool 9.00 BETA061
hassle-free overhere ...

_________________
https://dreamstream.mobi

Currently live processing ST 9.02 , testing upgrade to auto equalizer offline using slightly modified 3 FM settings Bojcha


Top
   
PostPosted: Sat Apr 07, 2018 9:48 pm 

Joined: Sat Jul 16, 2016 4:54 am
Posts: 10
Quote:
DynaRider_NEW_v0.00.50-HD_ST_9.00b060.sts
DynaRider_NEW_v0.00.42-FM_50us_ST_8.55b059.sts

FM Version need to catch HD version.
Bojcha is the HD preset ok for use on web radio?


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 759 posts ]  Go to page Previous 149 50 51 52 5376 Next

All times are UTC+02:00


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited